Windows XP skiva med integrerade Sata-Raid Drivrutiner


DAson
 Share

Recommended Posts

Kan det vara möjligt att få XP att fungera på en Sata2 disk? Om man så integrerar Sata-Raid Drivrutiner på skivan. Sist när jag gjorde det så var det mitt gamla MSI Moderkort som har Sata stöd och XP funkade klockrent där. Så då borde väl göra med detta Moderkort med som heter Gigabyte. Har denna tråd hamnat i fel del i forumet så kan det rättas. Har gjort en XP Pro SP3 skiva med Sata-Raid Drivrutiner integrerat. Nån som vet!?!

//DAson

Link to comment
Share on other sites

Som vi nyligen var inne på i en annan tråd så är SATA drivers inkulderade på XP skivan sedan någon av servicepackarna. Eftersom SP3 är den senaste ska det garanterat finnas där. Men huruvida det funkar med exakt alla moderkort vet jag inte. Det är väl inte svårare än att boota från skivan och kolla. Hittar den hårddisken vid momentet där du väljer var du vill installera XP så funkar det ju, där är det inte för sent att avbryta installationen vad jag minns.

Link to comment
Share on other sites

Jo det visste jag att fanns i SP3 Satadrivrutiner men jag valde att integrera det för säkerhetsskull. Windows XP har jag inte haft på Sata2 disk förr det går inte med mitt moderkort har jag hört och det därför jag har haft Windows installerat på en IDE disk. Så nu vet ni orsaken till att jag inte kunnat ha Windows på en Sata2 disk, har haft liksom problem med att ha Windows XP installerat på en Satadisk men funkar klockrent på en IDE-disk. Men prestandan är väl bättre på en Satadisk än det är på en IDE disk!?!

//DAson

Edited by DAson
Link to comment
Share on other sites

Som vi nyligen var inne på i en annan tråd så är SATA drivers inkulderade på XP skivan sedan någon av servicepackarna. Eftersom SP3 är den senaste ska det garanterat finnas där. Men huruvida det funkar med exakt alla moderkort vet jag inte. Det är väl inte svårare än att boota från skivan och kolla. Hittar den hårddisken vid momentet där du väljer var du vill installera XP så funkar det ju, där är det inte för sent att avbryta installationen vad jag minns.

På XP-skivorna finns det drivrutiner för en del SATA-styrenheter (controllers), men långt ifrån alla. Det är många som har problem även med installationsskivor med XP SP3.

Link to comment
Share on other sites

Många lite äldre moderkort har stöd endast för SATA1, och då hjälper inga drivrutiner i världen... det går helt enkelt inte att boota på en SATA2 disk. Det går däremot utmärkt att ha SATA2-diskar som lagringsenheter, eftersom windows kan hysa drivare för det, men dom läses som sagt inte in förrän operativet startar. Installera Windows på en SATA2-disk kan man göra genom att lägga till drivare för det... antingen från diskett, usb eller integrerade på XP-skivan, men så fort installationen är klar så sitter man där igen med en obootbar disk.

Edit:

Vad du kan göra är att försöka få tag i en första generationens Raptor-disk... den kör SATA1. Och är faktiskt snabbare än vanlig SATA2-disk. Förväxla bara inte med Velociraptor, som kör SATA2.

Edited by e-son
Link to comment
Share on other sites

Mitt moderkort stöder endast sata1, men jag har en sata2-disk som systemdisk. Installerade XP med SP3 (men inget annat) integrerat.

Kan du möjligen ha fått en uppdaterad bios, med just det stödet tillagt? Det är ju faktiskt bios det hänger på... inte hårdvaran!

Jag sitter själv med en P4-burk utan stöd för SATA2... ett av dom moderkort som aldrig fått någon sådan uppdatering i bios.

Edited by e-son
Link to comment
Share on other sites

Bios är från 2004-09-24

Det säger mig inte så mycket i och för sig... frågan är mer om den har uppdaterats med sata2-stöd. Min har det inte, och jag kan inte boota från sata 2. Jag har provade många gånger och på olik sätt innan jag förstod vad som var fel... och varje gång kom jag till samma punkt... första omstarten vid installation, sen var det kört.

Link to comment
Share on other sites

Nej, vi har ju haft den här diskussionen tidigare, och jag hade ingen bra förklaring då heller. Kan bara konstatera att vissa moderkort från tiden före och runt SATA2´s införande, inte kan boota från en SATA2-disk. Jag har som sagt ägnat åtskilligt med tid åt detta med min egen burk då det begav sig, och den vägrar bara boota ett system på sata2, medans allt annat fungerar ypperligt. Just nu körs den på en Raptor-disk, alltså SATA1.

Någon dokumentation eller förklaring till fenomenet har jag heller aldrig lyckats hitta. Jag har däremot sett exakt samma problem på flera andra datorer, med det gemensamt att dom tillverkades före SATA2´s införande.

Link to comment
Share on other sites

Men SATA 1 och 2 ska väl vara kompatibla på båda håll? Bara det att man endast kan utnyttja hastigheten från den svagaste länken.

Problemet är att hårdvaran eller bios inte är frammåtkompatibelt... åtminstone har jag aldrig lyckats hitta någon annan förklaring.

Edit:

Den som kan åstadkomma en annan, bättre dokumenterad förklaring kommer att imponera stort! ;)

Edited by e-son
Link to comment
Share on other sites

Från Wikipedia:

Given the importance of backward compatibility between SATA 1.5 Gbit/s controllers and SATA 3 Gbit/s devices, SATA 3 Gbit/s autonegotiation sequence is designed to fall back to SATA 1.5 Gbit/s speed when in communication with such devices. In practice, some older SATA controllers do not properly implement SATA speed negotiation. Affected systems require the user to set the SATA 3 Gbit/s peripherals to 1.5 Gbit/s mode, generally through the use of a jumper, however some drives lack this jumper. Chipsets known to have this fault include the VIA VT8237 and VT8237R southbridges, and the VIA VT6420, VT6421A and VT6421L standalone SATA controllers. SiS's 760 and 964 chipsets also initially exhibited this problem, though it can be rectified with an updated SATA controller ROM.
Link to comment
Share on other sites

För att sammanfatta...!

Jag hade rört ihop detaljerna en aning vad gäller var felet låg, jag hade för mig att det var i bios men det var alltså chipset. Det förändrar dock ingenting av det jag skrev i mitt första inlägg... datorer vars moderkort har något av dessa felaktiga chipsets kan inte boota från SATA2 eftersom den nödvändiga sata/raid-drivrutinen läses in först när windows startar. Man skulle så klart kunna tillföra drivrutinen externt vid varje enskilt boot-tillfälle, precis som man gör vid installationen, men hur det skulle gå till rent praktiskt vet jag inte.

Edited by e-son
Link to comment
Share on other sites

Den första dator jag byggde var med MSI 865PE Neo2 och två Maxtor SATA 1 diskar. När jag ställt in BIOS rätt har jag här utan problem installerat både XP Sp1 och 2000 Sp4.

Datorn jag har idag innehåller ett Gigabyte GA-EP45-UD3R och fyra WD SATA 2 diskar. Här var det bara att installera bägge OP utan att använda några disketter eller annat. Men när jag ville köra senaste datorn i med XP i AHCI mode krävdes det en diskett och BIOS ändring vid en installation av XP. Samma sak krävs om man vill köra i RAID.

Link to comment
Share on other sites

Lite ny info ang. problemet med felaktig chipset! Det går tydligen att tvinga fram SATA1-läge på dom flesta SATA2-diskar med en "Jumper-konfiguration" på baksidan av disken... här kommer några länkar!

Maxtor SATA Drive jumper configuration

Samsung SATA Drive jumper configuration

Seagate SATA Drive jumper configuration

Western Digital SATA Drive jumper configuration

...där ser man vad några års ytterligare google-vana kan göra...! :rolleyes:

Får väl också tillägga att jag inte provat detta, men kommer att göra vid något tillfälle.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share