Jump to content

Recommended Posts

Kan jag få lite hjälp med en Excel formel?

Om jag vill summera några celler men vill att summacellen skall vara tom tills jag skriver något kan jag skriva så här =OM(C21<>"";C20+C21;""). Men om det nu är många celler som jag vill summera kan jag använda summaformeln =SUMMA(B10:B60).

Hur kan jag kombinera dessa formler?

Link to comment
Share on other sites

Tack singlemalt.

Jag trodde jag skrev så men tydligen inte. Även efter ditt förslag blev det fel flera gånger. Vet inte vad som var fel, men nu har det blivit rätt.

Så återigen Tack för hjälpen.

Kan jag komma med en fråga till?

Som ni vet kan man markera flera flikar om man vill att de skall bli exakt lika. Men nu vill jag ha in en tabell också men om jag har flera flikar markerade så blir tabellverktyget gråat. Finns det något sätt att fixa till det ändå. Det är ju inte bra formlerna som skall vara lika på alla blad utan även storleken och allt. (Utom siffrorna förstås)

Edited by CGD
Link to comment
Share on other sites

Bra tipps singlemalt.

Det där var en för mig okänd metod. Jag har Office 2003 så det ser inte helt likadant ut men det fungerar. Helt perfekt är det däremot inte eftersom det bara kopierar formler rakt av och inte tar hänsyn till att det är ett nytt blad. Men all storleksformatering hänger med och formler där beräkningen bara är på ett blad fungerar ju.

Link to comment
Share on other sites

Bra tipps singlemalt.

Det där var en för mig okänd metod. Jag har Office 2003 så det ser inte helt likadant ut men det fungerar. Helt perfekt är det däremot inte eftersom det bara kopierar formler rakt av och inte tar hänsyn till att det är ett nytt blad. Men all storleksformatering hänger med och formler där beräkningen bara är på ett blad fungerar ju.

När det gäller kalkylprogram så får du faktiskt räkna med att du behöver gå igenom bladen, tabellerna och de enskilda cellerna som du kopierar och göra korrigeringar så att fliken heter t.ex. februari 2010 istället för januarai 2010 (2), att summeringar inte syftar på tidigare blad utan på det aktuella och att tabeller summerar den aktuella tabellen och så vidare. Alltså normalt efterarbete.

När du väl ha gjort det grundläggande arbetet så behöver du ju inte fundera på grundinställningarna förrän vid nästa kopiering.

Lycka till!

Link to comment
Share on other sites

Perbear, jag vet att det är en massa uträkningar och formateringar som skall till. Många gånger behöver man ju inte skriva ut alla utan man kan bara ta tag i cellen och dra iväg med den så fixar Excel till så att samma formel blir rätt i varje ruta. Men jag är ingen van Excel användare så det kan vara bra att fråga för Excel kan mer än vad man först kan tro. Singlemalt har levererat ett par användbara nyheter.

Link to comment
Share on other sites

En fråga till.

Jag behöver summera några celler.

Om det ser ut så här B12+B13+B14+B15+B16+B17 då kan jag använda SUMMA formeln, =(SUMMA B12:B17). Fördelen med detta är att om jag bara fyller i B14 så räknas det ut och värdet skrivs.

Om det istället ser ut så här B12+B17+B28+B35 och det däremellan finns andra värden måste jag skriva =(B12+B17+B28+B35). Nackdelen här är att om bara B17 är ifylld så räknas svaret inte ut och jag får istället värdefel. Finns det något sätt att skriva så att summan räknas ut även här. Eller kan man kopiera cellerna B12+B17+B28+B35 till B212 till B215 och där göra en uträkning och sedan kopiera svaret till den cell jag vill ha värdet.

Link to comment
Share on other sites

1) =summa(B12:B17) funkar perfekt

2) strunta i ( och ). =B12+B17+B28+B35 ska fungera med bara belopp i B17. Vad har du för formel i de cellerna?

post-2489-1269005198,31_thumb.jpg

Du kan också använda =SUM(B12:B35) under förutsättning att du inte har några värden emellan. Eller =SUM(B12;B17;B28;B35)

/G

Link to comment
Share on other sites

Tack odenxt.

Jag vet inte vad som blev fel. Jag såg dina förslag och tänkte rätta till mina egna. Men nu fungerar de?!

Så här har jag skrivit. Den första var lättare med alla celler i rad. Formel i cell B18, =OM(B17<>"";SUMMA(B13:B17);"")

I den andra ligger inte cellerna i rad och andra värden finns emellan och det var här det krånglade till sig.Formel i cell B28, =OM(B17<>"";B9+B13+B14+B16+B17;"") Om någon cell förutom då B17 inte var ifylld fick jag inget svar. Men nu, utan att jag gjort någon ändring fungerar det. Odenxt jag noterade ditt sätt att skriva en summa på celler som inte sitter ihop.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...