Jump to content

Installera mer RAM i Vista Ultimate 64-bit


Begva
 Share

Recommended Posts

Hej!

Kör 2 GB RAM i mitt Vista Ultimate 64-bit, fungerar felfritt.

Men när jag installerar mer, totalt 4 GB eller 6 GB, så startar inte Windows. Bara svart skärm efter BIOS laddat klart.

Har även testat att starta med skiva och andra startalternativ, detta funkar inte heller, ingenting händer då Windows ska ladda.

BIOS visar all installerad RAM som att det ska fungera.

Lite tungt att köra Vista med 2 GB ram ibland. Därför vill jag verkligen få detta att funka.

Är det någon konfiguration man kan göra i Vista så den tar mer RAM?

Trodde verkligen inte det skulle vara några problem att bara sätta in mer RAM så poff skulle det funka, som de gjorde förr i tiden.

------------------

System Information

------------------

Time of this report: 10/20/2010, 18:55:58

Machine name: BEGVA

Operating System: Windows Vista Ultimate (6.0, Build 6002) Service Pack 2 (6002.vistasp2_gdr.100608-0458)

Language: Swedish (Regional Setting: Swedish)

System Manufacturer: MSI

System Model: MS-7250

BIOS: Default System BIOS

Processor: AMD Athlon 64 X2 Dual Core Processor 6000+ (2 CPUs), ~3.0GHz

Memory: 2046MB RAM

Page File: 1724MB used, 2618MB available

Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

DxDiag Version: 7.00.6002.18107 64bit Unicode

// Henrik

PS. Vista supporten på Windows supportsida verkar helt korkad, skrivit in mitt produkt ID tusen gånger men den går ändå inte. Så går inte att få någon support därifrån.. helt värdelöst.

Link to comment
Share on other sites

Är du säker på att dina nya minnen är helt kompatibla både med moderkortet och med de tidigare minnena (om de sitter kvar)? Alla minnena behöver t ex fungera med samma minnesspänning.

Det är inte helt ovanligt att man behöver höja minnesspänningen i BIOS när man har mycket minne.

Har du prövat med att köra ett minnestest från en CD-skiva? Då får du ju samtidigt en test av om datorn över huvud taget kan fungera eller om det är totalstopp även för enkla uppgifter.

http://www.memtest.org/

Edited by Cecilia
Link to comment
Share on other sites

Nice ett svar!

Ja, jag har kollat så minnena är kompatibla med moderkortet på deras hemsida.

Just nu sitter jag och skriver med 1x 2GB minne installerat, en av de nya alltså.

Har testat alla olika kombinationer, alla på totalt 2GB funkar. Så fort jag vill öka så får jag att windows inte vill ladda (svart skärm).

Det ända jag kan testa nu är att ominstallera Windows, men det ska jag inte behöva göra känner jag. Detta borde gå att fixa i Windows på något sätt.

Och ja, jag har testat med memtest. Alla minnen är ok där.

Edited by Begva
Link to comment
Share on other sites

http://www.msi.com/index.php?func=proddesc&maincat_no=1&prod_no=251

Och minnena jag har finns med i listan här:

http://www.corsair.com/configurator/product_results.aspx?id=9701#other_modules

TWIN2X4096-6400C5 DDR2-800 (XMS2-6400C5) 4GB Kit (2 x 2GB) 1.8v 5-5-5-18-2T

Dessa vill jag få att fungera, men kan endast köra 1 x 2GB minne.

Edited by Begva
Link to comment
Share on other sites

http://www.msi.com/index.php?func=proddesc&maincat_no=1&prod_no=251

Och minnena jag har finns med i listan här:

http://www.corsair.com/configurator/product_results.aspx?id=9701#other_modules

TWIN2X4096-6400C5 DDR2-800 (XMS2-6400C5) 4GB Kit (2 x 2GB) 1.8v 5-5-5-18-2T

Dessa vill jag få att fungera, men kan endast köra 1 x 2GB minne.

Vilken minnesspänning är inställd i BIOS?

Du har ju köpt sådana för 1,8 V men du kan ju se att det även finns minnen för 2,1 och 2,2 V i listan.

Link to comment
Share on other sites

Alltså har du 2 eller 3 st 2 gb stickor?

När du installerar dessa installerar du då 1 i DIMM1 samt 1 i dimm3 eller dimm1 och dimm2?

- To enable successful system boot-up,always insert the memory modules into the DIMM1 first.

Edited by si3rra
Link to comment
Share on other sites

Det har troligen med inställningar i bios att göra, spänningen kan vara en av dom. Det har också släppts ett stort antal fixar i bios, varav en förbättring av minneskompatibiliteten. Är det inte redan gjort, så rekommenderar jag en bios-uppgradering. MSI Live Update kan troligen göra jobbet om du inte vill göra det manuellt.

Link to comment
Share on other sites

Tacksam för svaren, vi ska lösa detta!

Minnesspänningen i BIOS är inställt på 1.8V.

Jag har 1 x 2GB minne på DIMM1, fungerar felfritt.

Sätter jag in 1 x 2GB minne på DIMM3 (dual-channel), så bootar dator upp, räknar upp 4GB minne i BIOS, men Windows laddas inte, bara svart skärm.

Har kört alla senaste drivers från MSI, kollat även med MSI Live Update och kört alla som hittades där.

Åter igen, BIOS startar upp normalt med alla minnen i, men inte Windows. Windows startar endast med 1 x 2GB minne, eller 2 x 1GB minne, (dual-channel). Totalt 2GB.

Edited by Begva
Link to comment
Share on other sites

Hej igen.

Jag hittade en inställning vid startinställningar i msconfig, där man kan sätta processorantal och minne.

Ändrade minne till max som jag kunde skriva in, vilket var 2048 då jag hade 2GB minne i.

Stängde av datorn, satte i 4GB, startade upp och windows laddades! Woho!

Men sen när jag går in i msconfig igen så kan jag fortfarande inte ändra startminnet där till mer än 2048.

Har skickat med en bild här så förstår ni bättre.

Det måste ju gå att lösa detta på något vis i Windows.

post-13484-068857600 1287727959_thumb.jp

Link to comment
Share on other sites

Det kunde vara intressant att se om felet kvarstår vid en ominstallation (clean install) av Windows. Skulle det kunna vara ett alternativ? Anledningen är att jag börjar misstänka någon form av hårdvarufel.

Edit:

Ett litet test du skulle kunna göra först, är att åsidosätta "Dual Channel" genom att sätta minnesmodulerna i DIMM 1 och 2.

Edited by e-son
Link to comment
Share on other sites

Har testat skillnad på single och dual chan nu. Sitter på 4GB single chan installerat men fortfarande samma visa som bilden visar.

Krets på moderkortet? Hur kommer det sig då jag testat alla DIMM slotsen och alla minnen på alla olika sätt och alla fungerar.

Sätter jag in mer än 2GB så funkar det fortfarande, men Windows startar bara med 4GB om jag sätter denna MSconfig setting till 2048.

Detta måste ju vara nån simpel inställning i windows bara som gör att den bara använder 2GB, inget mer. Och denna måste ju gå att ändra.

Edited by Begva
Link to comment
Share on other sites

Hårdvarufelet är som sagt bara en vag misstanke men normal logik gäller oftast inte när det kommer till elektroniska kretsar, särskilt inte felaktiga sådana, så tro mig... det är absolut ingen omöjlighet. Jag vill fortfarande förorda ominstallation med 4GB minne korrekt installerat från början. Jag kan naturligtvis ha fel men har en känsla av att det skulle lösa problemet, förutsatt att det inte är hårdvarufel.

Edit:

Hittade just ett tips på nätet...! Under "Memory Configuration" i BIOS finns en post som heter "Software Memory Hole"... se till så den är aktiverad.

Edited by e-son
Link to comment
Share on other sites

Hej igen.

Tyvärr, har Software Memory Hole aktiverat, och har testat deaktivera också.

Och den där patchen från microsoft kan jag inte installera. Kommer upp ett litet fönster som söker genom Windows Update något, sen efter ett tag står det "Uppdateringen gäller inte för denna dator."'

Ja, jag har laddat den riktiga 64-bits versionen. Jag tror mer på att jag redan har det installerat eller att jag har något senare i mina uppdateringar eftersom det var länge sen den där kom.

Har läst igenom ett jättestor forumtråd på en sida med folk med samma problem sedan 2007. Alla visar olika lösningar och vissa löser de sig för å vissa inte, har testat många saker av det som dom skrivit.

Det jag har kommit fram till är i MSConfig så går det att ställa in hur mkt RAM som Windows ska starta med. Går jag sedan in i cmd och bcdedit så visas truncatememory där samt min inställning på den.

Bilden visar detta.

post-13484-024008100 1287874974_thumb.jp

Link to comment
Share on other sites

Hej, tack för svar. Men det var just detta som jag testade. "Software Memory Hole".

Sätter jag denna till Disable i BIOS räknar den upp 3GB av totalt 4GB installerat och Windows startar inte.

Sätter jag denna till Enable i BIOS räknar den upp 4GB av totalt 4GB installerat och Windows startar inte.

"

64-bit. 4GB. Memory remapping

<-------minne------->...............<--IO---><------minne------>

Allt minne tillgängligt eftersom bios flyttar upp en del av minnet ovanför 4GB. På så sätt lämnas ett hål tillräckligt stort för IO, och allt minne blir tillgängligt

64-bit. 4GB+

<-------minne------->...............<--IO---><------minne------------>>>

Som ovan.

"

från sweclocker.

Vet ni om jag köpte mitt Windows Vista 64 2007, om supporten finns kvar för det?

När jag går in på Windows Support Center så får jag skriva in mitt PID (Produkt-ID) för att gå vidare, eller så får man betala 600kr. Men när jag skriver in mitt ID så står det Ogiltigt eller Fel. Och ja, jag har aktiverat det så det är rätt och ska vara rätt nr.

Edited by Begva
Link to comment
Share on other sites

Kanske ett långskott, men på första skärmdumpen visar du en inställning med högsta antal minnesmängd (2048) vad händer om du inaktiverar detta med att ta bort bocken?

Edit:

Ser att du skall sälja minnena, men annars har jag kollat på min burk (win7) och jag har varken minnesmängd eller antal cpu ibockade...skulle kunna vara detta som är problemet.

Edited by cjb
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...