Inbyggd kortläsare [LÖST]


Recommended Posts

Jag har ett delikat problem. Jag har skaffat en laptop till frugan... samma som min jobbdator, en HP 6530b. Den har en inbyggd kortläsare på sidan. När frun stoppar i ett minneskort från en kamera i den så händer inget. Den dyker upp i utforskaren men ingen automatisk uppspelning sker. Inte heller tillfrågas hon vad hon vill göra.

För mig är det ju inga problem att bara kopiera över bilderna till en mapp på hårddisken...men för frun är det katastrof.

Jag har försökt att via kontrollpanelen aktivera import för bilder men det går inte. Kopplar jag på en extern hårddisk eller en USB-sticka så fungerar det. Men den interna kortläsaren vill inte.

Finns det någon som sitter på ett värdefullt tips?

(Windows 7 Ultimate)

// Manneman

Länk till inlägg
Dela på andra webbplatser

Har inte kortläsaren specifikt angiven i kontrollpanelen/automatisk uppspelning. Däremot är bilder valda för import. Funkar dock inte för kortläsaren...

Någon aning om numret på uppdateringen?

Sent from my Hero using Tapatalk

Länk till inlägg
Dela på andra webbplatser

Har provat att installera drivrutiner från HP´s sida istället för de som tillhandahålls från MS via installation/WU. Har även testat att avinstallera i enhetshanteraren för att sen få windows installera om den igen... samma problem ändå. På min egen 6530b fungerar detta bra...

Har slängt iväg frågan på HP´s forum så får vi se...

Länk till inlägg
Dela på andra webbplatser

Skumt problem,,hur ser det ut med firmware till burken ? USB 2 ? osv.. :unsure:

Allt "up to date"

Jag känner instinktivt att det är något registerrelaterat. Kortläsare fungerar ju fint med undantag av autostartfunktionen.

//Manneman

Länk till inlägg
Dela på andra webbplatser

Allt "up to date"

Jag känner instinktivt att det är något registerrelaterat. Kortläsare fungerar ju fint med undantag av autostartfunktionen.

//Manneman

Aha,, okay,, finns det mjukvara för någon kamera installerat ?

Länk till inlägg
Dela på andra webbplatser

Du menar digitalkamera? Nej!

Jag läste att det kan finnas en del program som kan ställa till det för Autoplay i registret. De eventuella program som skulle kunna ställa till det har jag bockat av under "tjänster" i MSCONFIG utan resultat. Lightscribe till DVD-brännaren var en stark kandidat. Men det är samma resultat.

Så jag ställer min fråga åter igen: jag hittar fixarna för registret gällande cd/dvd... vad ska jag leta efter när det gäller kortläsare? Får en känsla att det är registret som fått sig en känga.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom ... och kortläsare heter? :P

NoDriveTypeAutoRun registry key is used by Group Policy to configure whether to disable the Autoplay feature on all drives of the type specified. To check this setting, run Registry Editor (regedit), and navigate to the following registry key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

or (note that above registry value, if exists, will always supersede the below user-specific key),

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Locate the NoDriveTypeAutoRun registry entry on the right pane. The registry key is in DWORD hexadecimal value, which each bit determines which type of drive to disable or enable AutoPlay feature. There are many possible value for NoDriveTypeAutoRun, some possible NoDriveTypeAutoRun registry value data includes:

0×00000000 (0) enable all AutoPlay and AutoRun.

0×00000080 (128) disable AutoPlay on unknown reserved file type.

0×00000091 (145) default in Windows Vista and Windows 7.

0×00000095 (149) default in Windows XP.

0×000000B5 (181) disable AutoRun on CD-ROM drives, plus default unknown drive, removable drive (meant for floppy or ZIP), network drive and reserved drive type.

0×000000FF (255) disable AutoRun/AutoPlay on all drive types.

Thus, if the NoDriveTypeAutoRun registry value data is set to 0x000000B5 (181) or 0x000000FF (255), which disables AutoRun/AutoPlay on most or all drive types, the AutoPlay wont work when a drive is connected.

The best bet is to set NoDriveTypeAutoRun to default value as set by Windows 7 and Vista, which is 0×00000091 (hexadecimal) or 145 (decimal). Previous Windows version such as XP uses 0×00000095 (hexadecimal) or 149 (decimal). To enable AutoPlay on all drive types, set NoDriveTypeAutoRun to 0 (zero) or 0×00000080 (128) which only disable AutoPlay on unknown reserved file type.

NoDriveAutoRun registry key, which stored at the same registry location, meanwhile determine whether a particular connected drive should run AutoPlay function or not. When AutoRun is enabled on the drive, media is automatically started when it is inserted in the drive.

De båda rödfärgade sökvägarna har jag inte ens i registret...

//Manneman

Länk till inlägg
Dela på andra webbplatser

Fick tipset att göra dessa två registerfilerna:

1:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoActiveDesktop"=dword:00000001
"NoActiveDesktopChanges"=dword:00000001
"ForceActiveDesktopOn"=dword:00000000
"EnableShellExecuteHooks"=dword:00000001
"NoDriveTypeAutoRun"=dword:00000000

2:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000000

Hjälpte inte... :(

Länk till inlägg
Dela på andra webbplatser

Uppdatering: En bit närmare problemet.

Frun använder "Live Photo Gallery" från senaste Windows Live Essentials". Väl inne i det programmet så går det fint att importera från minneskort. Man måste dock klicka på "Importera" och då sätter processen igång. Ger detta någon hint till någon hur jag kommer förbi detta? Att avinstallera, eller rentav kassera programmet, är inget alternativ. För att citera frun: "jag vill ha det som på den andra datorn" (en stationär som numera står i förrådet)

Har kollat igenom inställningarna i Live Photo Gallery och hittar inget för att återställa till sitt ursprung.

/ Manneman

Länk till inlägg
Dela på andra webbplatser

Om du skapat de två registeravdelningarna så måste nycklarna dit med.

Lägg in denna nyckeln i registret och kolla igen.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

Som du ser så står det antingen 91 eller 145 beroende på om du väljer att redigera hexadecimalt eller decimalt. Prova och återkom.

Länk till inlägg
Dela på andra webbplatser

Om du skapat de två registeravdelningarna så måste nycklarna dit med.

Lägg in denna nyckeln i registret och kolla igen.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

Som du ser så står det antingen 91 eller 145 beroende på om du väljer att redigera hexadecimalt eller decimalt. Prova och återkom.

Hur kunde jag missa det? *slår mig för pannan*... La in värdet i båda posterna men tyvärr... samma effekt. Inget händer...

Tanken slog mig efter att ha läst ytterligare. Värdet 0 (noll) borde ju ha fungerat ändå, då det slår på AutoPlay för alla enheter?

Precis samma här. Oftast när frugan ska köpa något, så finns det inte, hur vi än letar i affärerna. Men att samma saker gällde med datorer, hade jag ingen aning om.

:lol:

Länk till inlägg
Dela på andra webbplatser

Eh...du startade om datorn efter ändringen?

Jag skulle kolla med att starta i felsäkert läge för att sedan kolla om den känner av SD-korten. (bara för att liksom), alternativt avinstallera kortläsaren i systemegenskaper och sedan låta den få installera sig igen.

Länk till inlägg
Dela på andra webbplatser

Självklart startade jag om datorn...

Så här är det:

* Kortet syns i Utforskaren

* Inne i Live Photo Gallery kan man importera genom en knapptryckning (processen ser lika dan ut men startar inte automatiskt)

* Kopplar jag en extern hårddisk eller mobilen så funkar det perfekt... Auto Import startar.

Jag har testat att plocka bort kortläsaren och låtit Windows installera den igen. Har även tagit bort drivrutinerna helt via enhetshanteraren och tagit hem dem via WU. Har gjort samma process men med de drivrutiner som finns på HP´s hemsida.

Länk till inlägg
Dela på andra webbplatser

Arkiverat

Detta ämne är nu arkiverat och det går inte längre svara i det.