Jump to content

Ett delikat nerladdningsproblem [LÖST]


Recommended Posts

Hej alla!

 

Jag sitter på en fiberanslutning 100/100 för tillfället. Har nyligen uppmärksammat ett problem som nu har börjat ställa till det för mig...

 

Att surfa på nätet är inga problem. Det går som tusan. Men när jag ska plocka hem filer av lite större storlek så händer det något. Nu pratar jag om filer som är allt mellan 50 mb och flera gb. Jag upplever inte problemen när jag går över en torrentklient utan när jag hämtar filerna direkt från t ex Mediafire eller SamMobile... det spelar ingen roll egentligen då felet dyker upp oavsett varifrån de plockas.

 

Nerladdningarna stannar upp... Allt är konstant, tiden kvar för nerladdning, hastighet osv. Det bara fryser. Klickar jag på "pausa" och sen igen "återuppta" så sparkar det igång igen. Ibland tillåts inte nerladdningen att göra så och det är oftast när man har fått göra någon typ av verifiering innan nerladdning. Jag kan även uppleva samma problem på t ex YouTube när jag strömmar ett längre klipp. Det enda som funkar då är en "refresh"

 

Jag har pratat med min ISP och dom hittar inga fel. Jag har provat flera olika routers (samma märke/modell) och felet består. Det spelar ingen roll vilken dator jag använder, det är samma... likaså vilken webbläsare jag testar. Har samma fel på Windows 7, Windows 8, Ubuntu och t o m Mountain Lion på sonens MacBook. T o m mobiltelefonerna har samma symtom.

 

Jag börjar nu misstänka att det är någon inställning i routern. Jag kör en D-link DIR 810L Dualband. Routern står i Default vad gäller inställningar. Det är bara SSID som jag ändrat. Routern har, som sagt, dualband och ger mig två nätverk... ett vanligt och ett på 5GHz. Det spelar ingen roll vilket jag kör på... problemet är detsamma.

 

Jag hittar inget liknande fel på D-Links supportsida. Har fått rekommendationen att uppgradera routern till den senaste Firmwaren, vilket är gjort. Har testat både den som kom vid leverans (har bytt den en gång) och även efter uppgraderingen till den enda tillgängliga uppgradering som finns. Problemet kvarstår! Har även samma fel oavsett om jag kör kabel eller Wifi

 

Vad ska jag kolla efter i detta läget? Eftersom jag inte upplever problem med vanlig surfning... utan bara när stora filer eller streaming ska hanteras. Och just "the bottom line"... via en torrentklient så fungerar det precis som det ska.

Link to comment
Share on other sites

Kanske långsökt men du har datorn anslutna till "båda" näten, kan det vara så att någon gång under nedladdningen så får ditt Operativsystem för sig att "oh nu är det bättre mottagning på 5 Ghz", eller tvärt om och byter nät genom att hoppa dit?. Gör det någon skillnad om du inaktiverar anslutningen till det ena.

Link to comment
Share on other sites

Nej, vad jag vet så kan man inte växla "per automatik" mellan de olika frekvenserna. Inte jag iallafall. Jag får helt enkelt logga in på det nätverk som jag vill/behöver. Som t ex min ena bärbara så syns inte ens 5GHz nätverket då mitt nätverkskort inte går högre än 2.4 GHz. Däremot har jag telefonerna anslutna på 5GHz nätverket, samt sonens Mac.

 

Men oavsett... detta fenomen är ju samma även via kabel. Så den trådlösa inställningen borde inte ha med saken att göra.

Link to comment
Share on other sites

Det jag först tänker på är mtu inställningen i routern. Om den default är inställd på ADSL och din hastighet är betydligt större än så, kan det bli fel där?

Torrenter delar upp i massor av små filer som laddas och påverkas sannolikt inte. Kan vara värt att testas.

Link to comment
Share on other sites

Det jag först tänker på är mtu inställningen i routern. Om den default är inställd på ADSL och din hastighet är betydligt större än så, kan det bli fel där?

Torrenter delar upp i massor av små filer som laddas och påverkas sannolikt inte. Kan vara värt att testas.

 

Intressant!

 

Det jag hittar i routerns inställningar är MTU satt på 1500 (default). Kollar man i routerns "Help" så står det följande:

MTU: The Maximum Transmission Unit (MTU) is a parameter that determines the largest packet size (in bytes) that the router will send to the WAN. If LAN devices send larger packets, the router will break them into smaller packets. Ideally, you should set this to match the MTU of the connection to your ISP. Typical values are 1500 bytes for an Ethernet connection and 1492 bytes for a PPPoE connection. If the router's MTU is set too high, packets will be fragmented downstream. If the router's MTU is set too low, the router will fragment packets unnecessarily and in extreme cases may be unable to establish some connections. In either case, network performance can suffer

 

Frågan nu är hur jag får reda på vad jag bör använda... är det min ISP som ska tillhandahålla ett korrekt värde? Eller är det något som ser ok ut?

 

Sen ska jag kanske tillägga att det inte är fel på hastigheten. Normal så plockar jag filer, både via torrenter och direkt från nätet på 70-80 mb/s

Link to comment
Share on other sites

  

Det jag hittar i routerns inställningar är MTU satt på 1500 (default). Kollar man i routerns "Help" så står det följande:

 

 

Jag har själv labbat med MTU'n under årens lopp, men för mig har felet aldrig legat där, så här står det på min router:

 

MTU-storlek

Det normala värdet för MTU (Maximum Transmit Unit) för de flesta Ethernet-nätverk är 1 500 byte, 1 492 byte för PPPoE-anslutningar, 1 436 för PPTP-anslutningar och 1 428 för L2TP-anslutningar. Vissa internetleverantörer kräver att man minskar MTU-värdet. Det behövs dock sällan och ska inte utföras såvida du inte är säker på att det är nödvändigt för anslutningen till internetleverantören.

Edited by Marion
Link to comment
Share on other sites

Man pingar till något ställe.. Och ökar eller minskar mtu tills man får igenom paketen utan att fragmenteras. Jag för min del ligger på 1472 med min 12-24 ADSL.

Sedan finns det en inställning till, men den kommer jag inte ihåg vad den heter, kollar när jag kommer hem i kväll

Link to comment
Share on other sites

All hjälp är tacksam...

Jag hittar rent spontant ingenting bland inställningarna. Däremot har det dykt upp lite nya frågor. Om de har med problemet att göra vet jag inte ännu. Tänkte ägna en stund att läsa lite innan jag ställer vidare frågor.

Link to comment
Share on other sites

Blir intressant..

 

Till saken, igen.

Det finns "Traffic Shaping" under QoS, där kan du ändra och laborera lite för bästa prestanda.

Det finns vinster att göra, men om det löser ditt problem är jag inte säker på.

 

Edit.

När du pingar mtu.. ping www.google.com -f -l xxxx

byt xxxx mot t.ex 1500, går den igenom utan problem.. öka med tio och pinga igen.

Går den inte igenom, minska med 10 till 1490 och pinga igen.

När du kommer ungefär.. öka/minska med ett i taget så hittar du din exakta mtu.

 

Ett tips till är att prova att ladda ner från ett internet café för att kolla om det är din ISP / Router som är problemet.

Edited by Venoms
Link to comment
Share on other sites

Ett tips till är att prova att ladda ner från ett internet café för att kolla om det är din ISP / Router som är problemet.

Jag har garanterat redan konstaterat att felet ligger i antingen router eller hos min ISP. Har felanmält till dom men dom ser inget problem. Ändå har dom satt ärendet under bevakning för att se om det kommer in liknande anmälningar från området.

Har i samma veva kollat med dem angående MTU och i deras "mallar" så ska det vara 1500... men killen jag pratade med verkar inte begripa vad det är.

Link to comment
Share on other sites

kan du koppla förbi/skippa routern så du kör på enbart fast kabel för att nå nätet ? vet inte hur ditt nätverk ser ut men det vore det lättaste för att felsöka om det beror på mjukvaran datorn,program,inställningar eller evl hårdvara routern.

 

mvh alex

Link to comment
Share on other sites

Jo, det står på agendan... men det krävs en del jobb rent inredningsmässigt. Ska bli ett projekt till helgen.

Har två följdfrågor dock:

1: Kabeln mellan väggen och routern... kan en skadad sådan ge dessa typer av problem? Det är en vanlig nätverkskabel.

2: Jag har gratis IP-telefoni av min ISP som uppenbarligen ska vara klar att använda. Bara att aktivera det via första inkoppling. Fick en speciell router till detta ändamål, men den är inte inkopplad ens. Den ska utgöra både Wifi-router och IP-telefoni. Jag frågade specifikt om jag var "tvungen" att använda routern om jag INTE ville ha IP-telefoni och dom svarade mig att så INTE var fallet. I händelse att jag använder min egen router så är allt som vanligt. Kan det vara så att IP-telefonin ligger och "tuggar" på anslutningen fast den inte är fysikt aktiverad ännu?

Jag upprepar det faktum att internetsurfning funkar utmärkt och även nerladdning via torrentklient. Det är endast filer som är lite större som spökar... Ett typexempel är ROM-filer i *.zip-format som kan hålla allt från 50 till 1500 mb. Strömmande filmer och små exe-filer... samma sak.

Link to comment
Share on other sites

Bredbandskollen och TPTest ger full "balle" varje gång jag gör testet... men TPTest larmade "Fail-timeout" två gånger av fyra testade. Båda gångerna vid nerladdning och vid de större paketen som togs emot.

Routern jag fick är någon NoName-historia. Men å andra sidan har jag inte ens kopplat in den, då jag inte är intresserad av IP-telefonin. Förrutom att köra #kabeliväggentest# i helgen så ska jag få låna en router av en kollega. På detta sättet borde jag ju kunna köra uteslutningsmetoden.

Å andra sidan så har jag redan avverkat en router av samma märke som den jag har nu, då jag var övertygad att den första var felaktig. Eftersom felet kvarstår så borde rimligtvis chansen vara minimal att nr 2 skulle ha samma fel... Istället så borde det ligga hos min leverantör eller då en inställning i routern som jag ännu inte har identifierat

Link to comment
Share on other sites

Har du testat att skapa en "Static Route"?

En statisk route har ingen, (har ingen vettig översättning men det heter) Network bandwidth overhead till skillnad mot en dynamisk som hela tiden måste uppdatera varje segment var 30:e sekund.. ungefär.

Så rent logiskt borde det inte påverka nerladdning av stora filer från nätet om du t.ex kan överföra stora filer lokalt mellan datorer utan att det händer något.

Värt att testa kanske..

Link to comment
Share on other sites

  • 2 weeks later...

Jag har nu testat att köra nätverkskabel direkt in i väggen... och fått samma problem, dock inte lika ofta. Nu är detta drygt en vecka sedan. Jag felanmälde igen till min ISP igen och inte fått någon respons över huvud taget på mitt ärende. Men hör och häpna... sedan förra veckan så verkar allt flyta på som det ska. Inga "dippar" eller avstannade nerladdningar. Helt från ingenstans funkar allt igen. Naturligtvis har min ISP startat om någonting längs vägen eller liknande....

Ser ärendet som löst men med en oidentifierad lösning. Har ställt frågan till min ISP över mail sen får vi se vad det kan ge. återkommer om något dyker upp.

// Manneman

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...