Arkiverat

Detta ämne är nu arkiverat och det går inte längre svara i det.

Gihega

SCCM 2012 R2

Recommended Posts

Hej!

Jag använder en fil som heter install.cmd med olika kommando för att installera program från SCCM 2012.

En av strängarna ser ut som följer....

copy /y Buildingblocks\*.* "C:\Users\%Username%\AppData\Roaming\Microsoft\Document Building Blocks\1053\14"

 

Problemet är att när SCCM 2012 kör detta så bytar den ut så %Username% (kontonamn) blir datornamn istället?!?!

SCCM 2012 kör allt som System.

Någon som känner till detta?

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Provat USERPROFILE istället?

copy /y Buildingblocks\*.* "%USERPROFILE%\AppData\Roaming\Microsoft\Document Building Blocks\1053\14"

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Provat USERPROFILE istället?

copy /y Buildingblocks\*.* "%USERPROFILE%\AppData\Roaming\Microsoft\Document Building Blocks\1053\14"

Hmm det skall jag prova. Tack

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Utan att veta helheten, så skulle jag gjort en msi som installerar filerna och lagt in en Active Setup i den som ser rill att filena kommer in vid inloggning. För jag misstänker att det inte finns någon adv. genväg som man kan använda.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser

Provade med %USERPROFILE% men det hjälpte inte. :(

Japp det körs lokalt men fortfarande av System.

SCCM kopierar ner hela mappen till C:\Windows\ccmcache\ och därifrån körs filen install.cmd.

Dela detta inlägg


Länk till inlägg
Dela på andra webbplatser