[LÖST] Vill komma åt 2 datorer med VNC, hur ställer jag in routern?


Recommended Posts

Har gått efter denna guide: http://www.portforward.com/english/routers...m/3c855/VNC.htm

Funkar bra för en dator, men hur gör man om man vill komma åt 2 st bakom samma router? Gjorde en likadan inställning på dator nr 2, men jag kan inte välja maskin vid inloggningen. Vad gör jag för fel?

Mycket tacksam för hjälp!

Mvh/ Valter

Link to comment
Share on other sites

Du kan inte använda samma port på bägge datorerna. Välj en lägre på den ena. Ex port 5900 på ena datorn, port 5910 på den andra, som du omdirigerar till rätt port (5900)

Link to comment
Share on other sites

Jag har inte heller denna router, men menyn ser liknande ut, jag har också 3Com. Men, nu har jag laborerat hit och dit med alla möjliga portinställningar, får det inte att funka. Jag fattar alltså inte hur jag får routern att skillja på datorerna. När jag loggar in på IP-adressen, så kommer jag bara till ena datorn, aldrig till båda, eller till att kunna välja vilken jag vill logga in på.

Följde guiden steg för steg, händer inget.

Tacksam för mer hjälp.

Mvh/ Valter

Link to comment
Share on other sites

Jag har inte heller denna router, men menyn ser liknande ut, jag har också 3Com. Men, nu har jag laborerat hit och dit med alla möjliga portinställningar, får det inte att funka. Jag fattar alltså inte hur jag får routern att skillja på datorerna. När jag loggar in på IP-adressen, så kommer jag bara till ena datorn, aldrig till båda, eller till att kunna välja vilken jag vill logga in på.

Följde guiden steg för steg, händer inget.

Tacksam för mer hjälp.

Mvh/ Valter

Du har väl inte samma ipadress till bägge datorerna? Ex till 192.168.1.1 har du vnc till port 5900, till 192.168.1.2 har du vnc till 5910, som du omdirigerar till 5900. Vilken 3Com-modell har du förresten? Sedan måste du ju förståss köra två vnc-n, en till varje dator.

Link to comment
Share on other sites

Nej, nej, inte samma på båda. IP adressen jag menade var routerns adress ut mot nätet. Men menar du att jag måste köra/starta VNC 2ggr för att kunna komma in på de respektive maskinerna? Men hur kan man välja vilken dator jag ska in på? Man anger ju inte nåt internt IP nummer inom nätverket vid inloggning. Eller är det bara för att jag inte lyckats konfiguera det hela på rätt sätt?

Den datorn som funkar att  komma in på är inställd på port 5500,5800,5900.

Den andra inställd på 5510,5810,5910, och är kopplad till port 5900 (Trigger 5900).

Får se om det hela funkar i kväll när jag kommer hem.

Återkommer annars med flera dumma frågor  ;)

Mvh/ Valter 

Link to comment
Share on other sites

Du ger inte rätt uppgifter!!! Hur loggar du in på vnc? Med routerns ip och lyckas komma åt en dator? Det verkar märkligt. Ska du komma åt datorerna hemifrån, alltså inom nätet? Har du två datorer så måste du ju vara aktiv på den ena, då räcker det ju att köra vnc på en dator. Jag har själv två datorer en med ubuntu, och det funkar utmärkt.

Link to comment
Share on other sites

Ursäkta om jag är lite otydlig.... så här är det:

Jag har 2 st stationära datorer hemma + en bärbar. Den bärbara tar jag med mig hemifrån ibland, och då kan det hända att jag vill in på mina stationära i hemmet. VNC är installerat på alla tre. Kör jag VNC hemma, i hemnätverket så kommer jag åt alla datorerna från alla. Inget problem där alltså.

Problemet uppstår när jag ska komma åt mer än en dator utifrån, dvs när jag loggar in på VNC på min bärbara utanför hemmet. Då matar jag ju in min IP-adress, som routern har från internet, ej routerns interna nummer inom hemnätverket. Då kommer det upp en ruta där jag ska mata in ett lösenord, vilket jag gör, och då kommer jag in på den ena datorn hemma, och alltid på samma. Har konfiguerat routern enligt guiden.

Under "Virtual Servers" ser det ut så här:

192.168.1.60  VNC  5500,5800,5900

192.168.1.134  VNC  5510,5810,5910

Under "Special Apps" ser det ut så här

          Trigger      Incoming ports      Enable

VNC          5900      5510,5810,5910      Yes

Och jag fattar alltså inte hur jag ska bete mig för att komma åt dator nr 2 i hemmet.

Tack för ditt tålamod!

Mvh/ Valter

Link to comment
Share on other sites

Ok, dåså.

För att komma åt 192.168.1.60 utifrån, skriv i vnc

internet-ip ex: 82.82.82.82

för 192.168.1.134

82.82.82.82::5910

Jag kör ultravnc men tror att de är lika, du bör läsa hjälp/manual för programmet du använder. (:: triggar portval). Sedan måste du ställa in, omdirigera port 5910 rätt i routern och vilken internt ip som ska svara på port 5910 (192.168.1.134) och vilken internt ip som ska svara på port 5910 (192.168.1.60). Ev om du kan välja 5910 som inkommande port i serverprogrammet i dator 192.168.1.134, då behöver port 5910 ej omdirigeras

Link to comment
Share on other sites

Tack, min herre!

Jag kom på att jag kanske skulle ändra inkommande port i VNC på den ena datorn till 5910, och när jag kör med ::5910 så funkar det! Men då förstår jag inte riktigt varför man ska "trigga" till port 5900, när man ändå inte kör på den porten på den datorn.

Du anar inte hur tacksam jag är!!

Mvh/ Valter

Link to comment
Share on other sites

Tack, min herre!

Jag kom på att jag kanske skulle ändra inkommande port i VNC på den ena datorn till 5910, och när jag kör med ::5910 så funkar det! Men då förstår jag inte riktigt varför man ska "trigga" till port 5900, när man ändå inte kör på den porten på den datorn.

Du anar inte hur tacksam jag är!!

Mvh/ Valter

Jo, det funkar inte att samma port svarar på två datorer därför ::5910, som du i routern ställt in att en av datorerna ska svara. Men eftersom vnc använder samma port i bägge datorerna, måste den porten omdirigeras till rätt port (5900). Hur som helst så klurade vi ju ut det till slut. Ändrade du så att vnc svarar på en annan port på ena datorn, så har inte omdirigeringen funkat. Du måste omdirigera rätt port på rätt dator.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share