Jump to content

Tilldela en cell TOM, dvs inget tecken eller värde eller något alls


Recommended Posts

Hej,

Jag vill i en OM-sats tilldela en cell att den ska vara tom ifall en cell på ett annat blad >0. Jag har provat skriva "" som argument, men det tilldelar ändå cellen något som jag sedan inte kan göra beräkningar med. ÄRTOM-formeln på en sådan cell returnerar dessutom FALSKT. Det fungerar visserligen i mitt fall att sätta 0 för att göra mina beräkningar, men överblicken blir värdelös när allt man ser är nollor över större delen av arket. Går det att tilldela en cell TOM eller liknande?

Tack för svar!

Link to comment
Share on other sites

En tom textsträng. 

=OM(A1>0;"";"inte större än noll")

Om formeln står i cell B1 så kan du använda 

=OM(B1="";"är tom";"är inte Tom"

Eller felvärdet SAKNAS(). Funkar bättre för vissa typer av diagram

=OM(A1>0;SAKNAS();"inte större än noll")

Ingen av formlerna ger "Sant" om du testar med

=ÄRTOM(B1)

Och den här ger inte heller t (även om det blir olika svar beroende på om du använder "" eller SAKNAS()) 

=CELL("typ";B1)

Och du lär aldrig få cellen att se helt tom ut eftersom det står en formel i cellen.

Du kan testa B1 Med saker i stil med:

=(B1="")

=ÄRSAKNAD(B1)
 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...