Problem med installation av Windows XP


sagstrom
 Share

Recommended Posts

Hej,

jag är ny här på forumet och har sökt en del i tidigare trådar men inte funnit något som kunde hjälpa mig med mitt problem.

Således frågar jag er där ute och hoppas att någon har upplevt samma konstiga problem och helst sitter inne på en lösning.

Så till själva problemet:

Jag har formaterat min kollegas Sony Vaio (som kom med Vista från början), för att installera Windows XP Pro.

Naturligtvis är det en orginalversion av XP som jag använder. Problemen börjar med att den bärbara datorn har en SATA-disk, och naturligtvis saknar floppy.

När man vill installera Windows XP på en hårddisk av SATA-typ är det som bekant inte säkert att hårddisken stöds av installationen. Därför finns möjligheten att trycka ned F6 för att lägga till eventuella nödvändiga drivrutiner. Smart kan man tycka, men självklart är den enda möjligheten för installationsprogrammet att ladda dessa filer - via en floppy. Eftersom datorn saknar floppy kan jag inte ladda några drivrutiner, och installationen misslyckas. För att råda bot på detta problem googlade jag lite och fann ett program (nLite) som erbjuder en smått fantastisk möjlighet: att duplicera orginalskivan till hårddisken, för att sedan bädda in de nödvändiga drivrutinerna till SATA-disken i installationen, skapa en ISO av hela rasket och sedan bränna ut ISOn på en ny tom skiva.

Sagt och gjort, glad i hågen gjorde jag mig en ny alldeles egen installationsskiva och succén lät inte vänta på sig - installationsprogrammet rullade igång och sedan det gamla vanliga: tryck på F8 för att acceptera - och vips ett nytt problem.

Installationsprogrammet upptäcker att det inte finns något operativsystem installerat på datorn, och så långt är allt väl. Men när jag sedan trycker på retur för att fortskrida med installationen kan installationsprogrammet helt plötsligt inte läsa cd-skivan (alltså inte orginalskivan) längre. Jag blir ombedd att sätta i en orginalskiva, vilket jag då naturligtvis gör, men inte heller den skivan går att läsa ifrån.

Jag har svårt att tänka mig att det är CD-ROMen som spökar, jag borde ha stött på patrull i ett tidigare skede i så fall. Orginalskivan är det definitivt inga fel på, således borde också den nya skivan vara felfri.

Har någon annan upplevt samma problem, eller är det någon av er som har några förslag på hur jag ska gå vidare?

Fråga mig gärna om detaljer om det är något som är otydligt.

Tack på förhand!

Link to comment
Share on other sites

Tyvärr samma problem igen.

Det går tydligt att höra hur CD:n snurrar igång, dock med samma resultat som tidigare.

Jag klurar lite på om det kan bero på det faktum att datorn är nyformaterad och att hårddisken (NTFS) inte nödvändigtvis heter C: längre. Är detta ett krav från XP för att installationen ska kunna fortskrida? Det är ju inte en dual boot jag är intresserad av.

Jag ska göra ett försök med Partition Magic och se om det leder någon vart. Om någon har någon annan teori får den gärna dela med sig.

Link to comment
Share on other sites

Tyvärr samma problem igen.

Det går tydligt att höra hur CD:n snurrar igång, dock med samma resultat som tidigare.

Jag klurar lite på om det kan bero på det faktum att datorn är nyformaterad och att hårddisken (NTFS) inte nödvändigtvis heter C: längre. Är detta ett krav från XP för att installationen ska kunna fortskrida? Det är ju inte en dual boot jag är intresserad av.

Jag ska göra ett försök med Partition Magic och se om det leder någon vart. Om någon har någon annan teori får den gärna dela med sig.

Du kan göra ett försök med att rensa hårddisken först... så att du startar nyinstallationen på en oformaterad, och helt ren disk. Active@KillDisk har en gratisversion du kan använda. Använd sedan XP-CD´n med SP3 integrerad... inga extra drivrutiner eller något annat. Det här har fungerat för mig några gånger.

http://www.killdisk.com/

Download Bootable ISO Image of Active@ KillDisk to burn CD

Edited by e-son
Link to comment
Share on other sites

Kom just på vad det handlar om... du måste fixa bootloadern för att kunna boota XP... sorry, men inte så lätt att komma ihåg alla turer med gamla OS! :rolleyes:

Så här gör du!

I med Vista-skivan och boota till recoveryconsole/återställningskonsollen. Vid prompten skriver du:

x:\boot\bootsect.exe /nt52 all /force

...x byter du ut mot cd-spelarens enhetsbokstav. OBS! Inte säkert att det är D:/ ...börja med D och arbeta dig uppåt i alfabetet tills du får svar i prompten att kommandot är utfört.

Sedan kan du byta till XP-CD´n (med SP3) och starta om samt installera som vanligt.

post-1936-1257324641,61_thumb.png

post-1936-1257324663,17_thumb.png

Edited by e-son
Link to comment
Share on other sites

Det gick fint att köra kommandot, detta avhjälpte dock inte problemet.

Jag ska prova det programmet du länkade till och se om det kan hjälpa.

Jag kanske ska tillägga att det är en Sony Vaio och att jag börjar misstänka att det är en bidragande orsak till problemen.

Finns det möjlighet att köra BIOS och CHIPSET-uppdateringar via en bootcd eller något liknande?

Edited by sagstrom
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share