Jump to content

Kommandot Kopiera och flytta till mapp


MrO

Recommended Posts

Hej! Jag gjorde den där förändringen kopiera och flytta till mapp i högerklicks menyn och nu när jag klickar på spela upp alla i fil  och mapp aktiviter om jag ska spela tex musik så kommer rutan kopiera till mapp upp samtidigt som musikspelaren startar,har jag gjort nåt fel eller är detta baksidan av att ändra dessa registernycklar?MrO

Link to comment
Share on other sites

Hej! Jag gjorde den där förändringen kopiera och flytta till mapp i högerklicks menyn och nu när jag klickar på spela upp alla i fil  och mapp aktiviter om jag ska spela tex musik så kommer rutan kopiera till mapp upp samtidigt som musikspelaren startar,har jag gjort nåt fel eller är detta baksidan av att ändra dessa registernycklar?MrO

Något fel är det nog.... har användt det hacket i åratal utan liknande biverkningar! Hur ser reg.hacket ut, som du använde?

Link to comment
Share on other sites

Hej e-son! jag följde instruktionerna under tipsomxp här på denna sida!

3}".När du flyttar eller kopierar en fil till en annan plats eller en annan hårddisk på datorn så markerar du först filen och sen börjar du leta efter kopiera/flytta-alternativet. Dom finns ju någonstans i verktygslisten ovanför fönstret. Men oavsett det så är dom inte helt lätta att hitta. Ett registertillägg kan lägga dom permanent i högerklicksmenyn, där du enkelt kommer åt dom. Starta registereditorn och navigera till

HKEY_CLASSES_ROOTAllFilesystemObjects shellexContextMenuHandle. Högerklicka sedan på en tom yta i det högra fältet och välj "Nytt/Nyckel", och döp den till "Copy To". Markera den nya nyckeln och ändra Data på Standardvärdet, i högra fältet, till "{C2FBB630-2971-11D1-A18C-00C04FD75D13}". Gör sedan om hela proceduren igen, men nu kallar du nyckeln för "Move To" och ändrar det värdet till "{C2FBB631-2971-11D1-A18C-00C04FD75D1 Du kan behöva starta om datorn för att tipset skall börja gälla.

Vet inte kan ha gått fel isånafall Mvh MrO

Link to comment
Share on other sites

Hej e-son! jag följde instruktionerna under tipsomxp här på denna sida!

Vet inte kan ha gått fel isånafall Mvh MrO

Ok... det är samma instruktioner som jag använder! Om högerklickskommandona "Flytta till" och "Kopiera till" fungerar som dom skall, så tror jag inte att det är där felet ligger... skulle tro att det är något annat fel som får den här effekten. Om du vill så kan du ta bort dom registernycklar som du har skapat, starta om burken, och sedan prova med min färdiga reg-fil istället, och se om du får samma fel.

Gå alltså i så fall till "HKEY_CLASSES_ROOTAllFilesystemObjectsshellexContextMenuHandle" och radera undernycklarna "Copy To" och "Move To"!

Efter omstart laddar du ner min bifogade reg-fil och klickar igång den! Det är bara att ta bort nycklarna en gång till om du får tillbaka samma fel!

Link to comment
Share on other sites

Hej e-son! Jag gjorde det som du sa o fick numera även funktionen "flytta till" som jag inte hade förut så nu är det 2 rutor som kommer upp :D skumt vaMvh mrO  Ps har även en egen mapp som heter "move to" direkt under shellex också,vet inte om det är rätt eller??

Link to comment
Share on other sites

Hej e-son! Jag gjorde det som du sa o fick numera även funktionen "flytta till" som jag inte hade förut så nu är det 2 rutor som kommer upp :D skumt vaMvh mrO  Ps har även en egen mapp som heter "move to" direkt under shellex också,vet inte om det är rätt eller??

Ja, ytterst skumt! Kan inte just nu komma på någon orsak!

Link to comment
Share on other sites

  Ps har även en egen mapp som heter "move to" direkt under shellex också,vet inte om det är rätt eller??

Nej det är helt fel... där ligger troligen felet! Ta en backup på den nyckeln och radera den sedan... få se om det avhjälper felet!

Link to comment
Share on other sites

Det här är med stor sannolikhet TYP ett fel som ofta uppstod redan i Win98, felet är att i svenska Win heter det

C:Program

Medans det i engelska Win heter:

C:Program Files

Du har med stor sannolikhet båda.

Vad som händer är alltså att nåt är installerat i C:Program Files, men C:Program öppnas istället först, eftersom det namnet kommer före det andra i bokstavsordning.

Kolla vilka program som ligger i Startup-mappen i startmenyn.

Ifall någon av dem har en sökväg utan citattecken runt, så öppnas mappen istället för programmet.

c:Program Filesdittdatt.exe

ska alltså vara:

"c:Program Filesdittdatt.exe"

Kan vara på nåt annat Start-Up-ställe också, t ex i registret.

Men det finns auto-fixar:

http://www.pekspro.com/

På den sidan finns det ett program att ladda ner som fixar felet.

Programmappsfixaren

/LbL!

Link to comment
Share on other sites

Hej e-son! provade att döpa om mappen men det gjorde ingen skillnad,vet inte hur jag ska ta en backup på nyckeln :-[ :-[ Hade fel mappen ligger under"ContextMenuHandle" inte som jag sa direkt under shellex

Mvh MrO

Det är under "ContextMenuHandlers" dom skall ligga! Vad gäller backup på registernycklar, så kan du bara högerklicka på nyckeln och välja "exportera"... sen spara den på lämplig plats med passande namn. Behöver man återställa så dubbelklickar man bara på backupen, som med alla .reg-filer!

Kommer inte på något mer just nu ang. själva felet, men hör av mig igen om något dyker upp!

Link to comment
Share on other sites

Hej LbL o e-son! Till dig LbL så hittade programmet ett fel  i registret som den åtgärdade o tycker att burken blev rejält kvick i uppstarten men det blev  tyvärr ingen skillnad på ursprungsproblemet :'(

till dig e-son så då vet jag att inte felet ligger där iallafall då,o tack för infon om hur jag säkerhetskopierar register nycklar alltid bra att veta ;) Får se om nån annan har några ideerMvh MrO

Hittade förresten 2 program i autostarten som inte hade dessa ",hur ändrar jag på det då??

Link to comment
Share on other sites

-> Hittade förresten 2 program i autostarten som inte hade dessa ",hur ändrar jag på det då??

Ja, Autostart heter det ju i svensk version, ja ...  --!!

Du högerklickar på programmets ikon där i Autostart, och väljer Egenskaper, och ser till att det i båda de översta rutorna ser ut typ:

"C:Program FilesASUSCool & Quietcnq.exe"

... så där!  Alltså med    "blaj"  runt hela filsökvägen och programnamnet.

/LbL!

Link to comment
Share on other sites

Hmmm, skulle kunna tänka mig att om det inte behövs några " runt om, så ändrar den tillbaks av sig själv.

Dvs om det inte är några S P A C E i programnamnen eller filsökvägen, så behövs det ju inte.

Här behövs det:

"C:Program FilesASUSCool & Quietcnq.exe"

Här behövs det inte:

C:ProgramFilesASUSCool&Quietcnq.exe

Ser du skillnaden ?!

/LbL!

Link to comment
Share on other sites

Du är inte ensam om problemet, redan 2005 skrev någon om samma sak, men tyvärr har han inte fått nåt svar...

http://forums.majorgeeks.com/showthread.php?t=159844

Mer P.S.

Nu hittade jag nåt annat här:

Instead of applying the tweak at the key above, do exactly the same at HKEY_CLASSES_ROOT*shellexContextMenuHandlers. This will make it work properly.

DET bör funka!

Byt alltså ut alla:

[HKEY_CLASSES_ROOTAllFilesystemObjectsshellexContextMenuHandlers]

i Registret, till:

[HKEY_CLASSES_ROOT*shellexContextMenuHandlers]

istället!

LÄS mer på:

http://windowsxp.mvps.org/movetocontext.htm

Där det också finns en länk till han som skrivit Move-To/Copy-To från början, och hans förklaring till varför det inte alltid funkar!

"When you ask them, "So do you handle the <X> command?" they say, "Oh yes! That's me!" This is fine in a toolbar, where the only time they're asked "Do you handle the <X> command?" is when the user clicks on the button. But in a context menu, you are asked this much more frequently, and with varying values of X.

So when Outlook launches an attachment, the shell loads up the context menu handlers and asks each one, "So do you handle the Open command?" The "Delete" option says, "Nope, sorry." So does "Cut" and "Send to" and "Sharing and Security". But "Copy To" happily says, "Oh yes! That's me!"

And then the Copy To dialog shows up when you don't want it."

PHAN vilken tur jag är så envis och sömnlös!

/Hepp!

Link to comment
Share on other sites

Hörrö lbl... hela första delen av ditt senaste inlägg har vi liksom redan testat ( http://www.alltomxp.se/forum/index.php?top...g98264#msg98264 )   ;)  ...andra delen är dock ingen dum idé... ett hack som hade fallit i glömska hos mig!  :-[

MrO...

Ta alltså bort dom registernycklar du har nu, och försök sedan med samma nycklar på nya platsen i registret. Säkrast är att starta om burken emellan! Koden ser ut som följer, och jag bifogar även en färdig .reg-fil om du hellre vill använda den!

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT*shellexContextMenuHandlersMove To]
@="{C2FBB631-2971-11D1-A18C-00C04FD75D13}"

[HKEY_CLASSES_ROOT*shellexContextMenuHandlersCopy To]
@="{C2FBB630-2971-11D1-A18C-00C04FD75D13}"

Edit:

Har föresten testat, och den fungerar i både XP och Vista... dock endast på filnivå!

Link to comment
Share on other sites

Hej e-son o lbl! Hmm den ena av er har 2 kommandon o den andra 3,vet inte om det gör nån direkt skillnad iof?! Jag har följt lbl´s ide  och det enda av dom problem som kvarstår av det som stod på den där sidan är just det som jag började med,alltså att när jag spelar upp alla tex låter så kommer rutan "sent to" och "copy to" upp! Tex det fenomenet att höger klicksmenyn blev seg har försvunnit,har inte testat alla :-[

Lbl,jag hade redan en del av dom där powertoys men jag har tagit hem TweakUI så jag ska testa det ;) Mvh MrO

Link to comment
Share on other sites

-> Hmm den ena av er har 2 kommandon o den andra 3,vet inte om det gör nån direkt skillnad iof?! Jag har följt lbl´s ide  och det enda av dom problem som kvarstår av det som stod på den där sidan är just det som jag började med,alltså att när jag spelar upp alla tex låter så kommer rutan "sent to" och "copy to" upp!

Har du MISSAT att raderna inte längre är likadana ??      ;)

Det är på ETT NYTT STÄLLE i Registret du ska lägga in det där nu!

(Men RENSA först bort det gamla!)

Här:

[HKEY_CLASSES_ROOT*shellexContextMenuHandlersMove To]

DÅ får du bort ditt problem med att ett Fönster öppnas!

Men LÄS nu ALLT på den HÄR sidan först, så du förstår!  Det bidde mycke' text inatt asså    :D

/LbL!

Link to comment
Share on other sites

Hej e-son o lbl! Hmm den ena av er har 2 kommandon o den andra 3,vet inte om det gör nån direkt skillnad iof?! Jag har följt lbl´s ide  och det enda av dom problem som kvarstår av det som stod på den där sidan är just det som jag började med,alltså att när jag spelar upp alla tex låter så kommer rutan "sent to" och "copy to" upp! Tex det fenomenet att höger klicksmenyn blev seg har försvunnit,har inte testat alla :-[

Lbl,jag hade redan en del av dom där powertoys men jag har tagit hem TweakUI så jag ska testa det ;) Mvh MrO

Som sagt... lbl´s idé hade vi redan provat, och det finns ingen anledning att ha med en redan existerande nyckel i koden... därav att jag bara har 2! Vad gäller TweakUI... så gör den exakt samma sak som du redan har gjort, när det gäller "kopiera och flytta till..". Den innehåller dock andra grejer som kanske kan vara bra!

Link to comment
Share on other sites

-> Som sagt... lbl´s idé hade vi redan provat

Sluta att förvilla honom ännu mer nu - han har ju ännu inte provat med det NYA STÄLLET i Registret!

Det du pratar om rörDE ju bara övre (numera borttagen!) halvan av mitt (något för) låååååånga inlägg Högst UPP på den här sidan.

:)

Så han har alltså inte alls "Som sagt... lbl´s idé hade vi redan provat" provat!

/LbL!

Link to comment
Share on other sites

-> Som sagt... lbl´s idé hade vi redan provat

Sluta att förvilla honom ännu mer nu - han har ju ännu inte provat med det NYA STÄLLET i Registret!

Det du pratar om rör ju bara övre halvan av mitt (något för) låååååånga inlägg Högst UPP på den här sidan.

:)

Så han har alltså inte alls "Som sagt... lbl´s idé hade vi redan provat" provat!

/LbL!

ajaaa... jag orkar inte käfta med dig

Link to comment
Share on other sites

Nej lbl jag har inte missat att flytta kommandona till det nya stället,har gjort precis som du skrev :)Därav skillnaden i bla att högerklicksmenyn inte längre är seg som det stod på den sidan att den kunde bli,men som sagt det andra kvartstår som sagt! Mvh MrO

Link to comment
Share on other sites

-> jag har inte missat att flytta kommandona till det nya stället

Menar du alltså att det FORTFARANDE poppar upp en Copy-to / Move-to ruta när du ska starta flera filer på en gång !?

KLART mystiskt eftersom det uppenbarligen har fungerat för de som skrev om det på de av mig inciterade länkarna överst här ?!

Är du SÄKER  ;)  på att du tagit bort kommandona - båda två - på de ursprungliga ställena ??   

/LbL!

Link to comment
Share on other sites

Japp kollade för säkerhets skull,både det gamla är borta o det nya ligger där det ska ;)

Ja det poppar fortfarande upp en Copy-to / Move-to ruta när jag ska starta flera filer på en gång,är väl nåt annat fel imitt register då antar jag :-[ Mvh MrO

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...