Problem med dual boot och uppstart


Benno
 Share

Recommended Posts

På min stationära dator har jag både Vista och XP installerade. Operativsystemen ligger på var sin hårddisk och jag önskar nu att formatera hårdisken med XP då det inte längre används. Problemet är att uppstartsfilerna verkar ligga på hårddisken med XP (den som ska formateras). När jag kopplar ut den disken startar inte Vista (som ligger på andra disken). Om jag bara ansluter disken med XP visas dual boot-menyn och XP kan startas.

Min fråga är hur jag ska lösa problemet. Min första tanke var att (med endast Vista-disken ansluten) köra Repair med Vistas installations-DVD. Förhoppningsvis kan den skapa en ny uppstartkonfiguration.

Jag vågar inte formatera XP-disken innan jag vet att Vista kan starta utan den. Några förslag?

Link to comment
Share on other sites

Min fråga är hur jag ska lösa problemet. Min första tanke var att (med endast Vista-disken ansluten) köra Repair med Vistas installations-DVD. Förhoppningsvis kan den skapa en ny uppstartkonfiguration.

Du har svarat på det själv.... koppla ur XP-disken och kör en "Startreparation" från Vista-skivan! Vista har egenheten att läga bootsektorn på annan disk om man har mer än en ansluten vid installationen!

Link to comment
Share on other sites

Du har svarat på det själv.... koppla ur XP-disken och kör en "Startreparation" från Vista-skivan!

Det fungerade tyvärr inte. "Startreparation" upptäcker visserligen ett fel, "Det finns ingen systempartition i partitionstabellen" och försöker återgärda det med "Reparation av partitionstabell", men det löser inte problemet. Jag har kört reparationen flera gånger med samma resultat.

Dessutom är det lite konstigt att inget operativsystem visas när jag ska välja vilket system jag vill reparera. Listan är helt tom, men genom att klicka nästa kommer jag ändå vidare.

Link to comment
Share on other sites

Det fungerade tyvärr inte. "Startreparation" upptäcker visserligen ett fel, "Det finns ingen systempartition i partitionstabellen" och försöker återgärda det med "Reparation av partitionstabell", men det löser inte problemet. Jag har kört reparationen flera gånger med samma resultat.

Dessutom är det lite konstigt att inget operativsystem visas när jag ska välja vilket system jag vill reparera. Listan är helt tom, men genom att klicka nästa kommer jag ändå vidare.

Skumt... men du kan prova att göra det manuellt då kanske! Koppla ur xp-disken och boota på Vista-skivan samt välj att reparera windows. I reparationsmenyn väljer du kommandotolken istället för startreparation, och i dosfönstret skriver du först bootrec /rebuildbcd... det söker igenom alla diskar efter vistainstallationer och låter dig förhoppningsvis välja att lägga till din installation till startkonfigurationen! Om det lyckas så skriver du bootrec /fixmbr, när den är klar skriver du bootrec /fixboot, innan du startar om och ser om det fungerade!

Link to comment
Share on other sites

Testade nyss med EasyBCD. Valde där någon typ av reparation vilken lyckades enligt programmet. Vid omstart vägrade dock systemet starta trots att jag anslut även XP-disken. Då kunde jag alltså inte starta alls, vilket gjorde mig smått nervös. Bestämde mig då för att återigen testa "Startreparationen" med endast Vista-disken ansluten. Den gjorde precis samma diagnos och reparation som tidigare men den här gången tog det lite längre tid och resulterade i att Vista startade upp som önskat (utan XP-disken ansluten). Problemet är alltså löst!

Nu återstår bara att formatera XP-disken. Tack för hjälpen!

Skumt... men du kan prova att göra det manuellt då kanske! Koppla ur xp-disken och boota på Vista-skivan samt välj att reparera windows. I reparationsmenyn väljer du kommandotolken istället för startreparation, och i dosfönstret skriver du först bootrec /rebuildbcd... det söker igenom alla diskar efter en vistainstallationer och låter dig förhoppningsvis välja att lägga till din installation till startkonfigurationen! Om det lyckas så skriver du bootrec /fixmbr, när den är klar skriver du bootrec /fixboot, innan du startar om och ser om det fungerade!

Mycket möjligt att det där är mer effektivt än den automatiska reparationen.

Link to comment
Share on other sites

Testade nyss med EasyBCD. Valde där någon typ av reparation vilken lyckades enligt programmet. Vid omstart vägrade dock systemet starta trots att jag anslut även XP-disken. Då kunde jag alltså inte starta alls, vilket gjorde mig smått nervös. Bestämde mig då för att återigen testa "Startreparationen" med endast Vista-disken ansluten. Den gjorde precis samma diagnos och reparation som tidigare men den här gången tog det lite längre tid och resulterade i att Vista startade upp som önskat (utan XP-disken ansluten). Problemet är alltså löst!

Kan hända att EasyBCD la till det som saknades för att startreparationen skulle fungera! Gott att det löste sig i alla fall! :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share