Jump to content

Problem med sökning och nedladdning i DC (Vista)


walker
 Share

Recommended Posts

Hejsan.

Jag är ny här och hoppas att ämnet hamnar på rätt ställe och att jag inte bryter mot några regler. Jag sökte på forumet men hittade ingen tråd som tog upp denna fråga.

Jag har ett problem som jag inte lyckas åtgärda. Det är så att jag inte kan söka eller ladda ned någonting i DC++ (AirDC++ närmare bestämt, men jag har testat andra klienter med) om jag inte har ställt in passive mode. I passive mode går det fint dock, men att använda sig av detta medför en del begränsningar vilket gör att jag vill kunna använda mig av active mode. Nu undrar jag som ni förstår varför det är såhär och fram för allt hur jag kan åtgärna det. Problemet uppstod för några veckor sedan när jag köpte en ny dator med Windows Vista, tidigare hade jag Windows XP och då hade jag inte detta problem.

Jag har Windows Vista Home Premium, endast Windows egna brandvägg (men problemet kvarstår även sedan jag inaktiverat den) och inget antivirusprogram installerat. Jag tror att jag har ett inbyggt nätverkskort (jag är ganska okunnig vad gäller datorer), i enhetshanteraren säger den att nätverkskortet heter NVIDIA nForce Networking Controller. Är det något jag missat?

Tack på förhand/ walker

Link to comment
Share on other sites

Jag menar alltså ett fiber-lan, ett privat fastighetsnät eller liknande. Kanske någon liten lokal ISP.... vad vet jag. LAN är det med all säkerhet i alla fall. Du kan ta kontakt med din leverantör och fråga om är instängd bakom någon brandvägg.

Link to comment
Share on other sites

Okej, jag förstår. Men borde inte det faktum att det fungerade tidigare och först slutade fungera efter att jag skaffade den nya datorn (med Vista) tala emot det?
 

Jo, det har du rätt i!

Jag tog en snabb titt i AirDC v2.01, och kan konstatera att utan vare sig brandvägg eller router, så borde det fungera med "Direct connection" i Connection settings. Du måste dock fylla i IP-nummer! Fungerar inte detta, så antar jag att det har med Vistas behörighetsinställningar att göra igen. Det verkar ju vara något som många har problem med.

Link to comment
Share on other sites

Jag har Windows Vista Home Premium, endast Windows egna brandvägg (men problemet kvarstår även sedan jag inaktiverat den) och inget antivirusprogram installerat... Är det något jag missat?

Ursäkta inbrytningen...

Hur är det med Säkerhetscenter ? Nog borde du fått en varning om att du saknar antivirusskydd !?

Att köra DC++ utan skydd är som att älska utan... :P Lägg åtminstånde in AVG gratisprogrammet.

Link to comment
Share on other sites

Ursäkta inbrytningen...

Hur är det med Säkerhetscenter ? Nog borde du fått en varning om att du saknar antivirusskydd !?

Att köra DC++ utan skydd är som att älska utan... :P Lägg åtminstånde in AVG gratisprogrammet.

Instämmer!... Att överhuvudtaget koppla i nätkabeln utan fungerande antivirus och brandvägg, är i dag inte att tänka på.

Link to comment
Share on other sites

Jag skall installera ett antivirusprogram, jag tog bort det jag hade för att se om det kunde vara det som var upphovet till problemet. Jag har fyllt i (rätt) IP-nummer. Angående behörighetsinställningar, vad är detta och hur felsöker jag där?

Tack för hjälpen / walker

Link to comment
Share on other sites

I Vista's brandvägg kan du bestämma vilka program som skall släppas ut.

Kontrollpanelen - Windows brandväggen - Tillåt ett program... (i vänster spalten)

Under fliken Undantag finns listan av godkända serverprogram.

Finns inte i AirDC++ ibockad eller ens med i denna lista så kan du manuellt "Lägg till program..."

Om programmet inte finns i nästa lista så Bläddra... fram till ditt CD++.

(Se även valet "Ändra omfång...")

När väl programmet ligger i första undantagslistan så kan du uppdatera "Läg till port..." och "Egenskaper".

Lite exempel på inställningar (med bildförklaringar).

Se speciellt "Part 2 - Port Forwarding" som liknar Vistas och DC++ uppsättningar.

http://www.dslreports.com/faq/dc?text=1

Lite citat uppsnappat på siter som också haft Vista problem med active mode.

Gå in i Settings / Advanced och markera av Register with Windovs to handle magnets. Sen fungerade det för mig
jag kör senaste Revconnect. Windows brandvägg aktiverad, och portarna öppnade i routern.

men som sagt e det viktigt att man har rätt ipnummer i connection settings.

har du kollat så du har rätt IP i "settings"->"connection settings"? Ibland måste man skriva i det manuellt.

Ditt ip kollar du lättast på http://www.whatismyip.com Klicka sen i "Active"

Link to comment
Share on other sites

Okej, var det vad 'behörighetsinställningar' innebar, i sådana fall har jag redan ställt in det, och portar för TCP och UDP är öppnade. Omfånget är inställt så att det skall gälla 'Alla datorer - inklusive de på internet'.

"Gå in i Settings / Advanced och markera av Register with Windovs to handle magnets. Sen fungerade det för mig"

Det minns jag att jag har stött på tidigare när jag ränt runt på internet på jakt efter en lösning, men det alternativet inte finns i mitt program. Det närmaste som finns är "Register with Windows to handle dchub:// and adc:// URL links" men jag antar att det är något helt annat.

"Lite exempel på inställningar (med bildförklaringar).

Se speciellt "Part 2 - Port Forwarding" som liknar Vistas och DC++ uppsättningar.

http://www.dslreports.com/faq/dc?text=1"

Här blir det lite för avancerat för mig. På ett ställe i FAC:en (under stycket "How to setup active mode? - if you are not behind a router") säger de: "Select the Direct Connection radio button.  Leave the IP fields blank. This will make DC++ use the current IP assigned to your network card. You must not have an internal IP address for this to work."

Jag vet inte om jag har någon intern IP-adress men jag hittar inget IP som börjar på 192.168... när jag skriver in "ipconfig" vid dos-prompten. Och använder jag den inställningen i AirDC++ så fungerar det inte.

Behöver man använda alternativet "Direct connection" när man inte använder router?

Vad gäller port forwarding delen så verkar det inte se så ut för mig. Om jag går in på egenskaper för mitt nätverkskort så kommer jag in till något helt annat, och om jag går in till undantagen för brandväggen och går in på egenskaper för AirDC++ där så kan jag inte ställa in något ip (I FAC:en så vill de att man skall ställa in sitt interna IP). Vart är de egentligen?

Jag är duktigt förvirrad.

Link to comment
Share on other sites

Det närmaste som finns är "Register with Windows to handle dchub:// and adc:// URL links" men jag antar att det är något helt annat.

Den är till för att du skall kunna klicka på länkar när du är ute på DC!

Behöver man använda alternativet "Direct connection" när man inte använder router?

Ja, det är just då du skall använda det alternativet

Vad gäller port forwarding delen så verkar det inte se så ut för mig. Om jag går in på egenskaper för mitt nätverkskort så kommer jag in till något helt annat, och om jag går in till undantagen för brandväggen och går in på egenskaper för AirDC++ där så kan jag inte ställa in något ip (I FAC:en så vill de att man skall ställa in sitt interna IP). Vart är de egentligen?

Jag är duktigt förvirrad.

Du skall inte göra någon port forwarding eftersom du inte har någon router.... därmed har du heller inget internt IP. Eller rättare sagt... det är samma som det externa.

Link to comment
Share on other sites

Okej, var det vad 'behörighetsinställningar' innebar

Nej detta är inte UAC -kontroller utan brandväggs hantering.

Jag tror inte detta över huvud taget har med behörighetskontrollen i Vista att göra.

You must not have an internal IP address for this to work

Intern IP är en så kallad svartadress... De finns inte på Internet och de börjar på t.ex. 10.x.y.z eller 192.168.y.z

De används alltså internt i lokala nätverk eftersom det finns inte nog men IP4 adresser för att varje dator

i hela världen ska få en egen adress. IP6 kommer däremot att ha tillräckligt med adresser för överskådlig framtid.

I FAC:en så vill de att man skall ställa in sitt interna IP

Om du har en router som plockar upp IP-adressen från din Internet leverantör, så kommer de innanför

liggande datorerna att tilldelas 'svartadresser' eller 'interna IP-adresser', eftersom alla interna datorerna

inte kan samsas om en adress. Detta sker via DHCP adresstilldelning från routern.

I ditt fall så har du antagligen endast en dator som är direktkopplad till Internet. I detta fall så har din

dator fått ta hand om den externa Internet adressen. Detta ser du på ditt nätverkskorts Status - Information.

P.S.  I enlighet med forumets stadgar så kan vi inte tipsa om annat än generella åtgärder som inte

        har med fildelning eller olovlig Internet aktivitet att göra. :-

Link to comment
Share on other sites

P.S.  I enlighet med forumets stadgar så kan vi inte tipsa om annat än generella åtgärder som inte

        har med fildelning eller olovlig Internet aktivitet att göra. :-

Det är bra att du upplyser!.... men när blev fildelning olovlig? Varken fildelningen i sig, eller dom olika fildelningsprogrammen är olagliga/olovliga. Att det sen förekommer delning av upphovsrättsskyddat material, är en helt annan sak, och självklart olagligt!    ;)

Link to comment
Share on other sites

Okej, så då är vi tillbaka på ruta ett med andra ord. Jag tar och plingar internetleverantören i morgon och frågar dels om det finns någon fildelningsspärr och dels om jag sitter bakom någon brandvägg av något slag även om detta förmodligen inte kommer ge någonting. Inga andra förslag?

Link to comment
Share on other sites

Jag har fiberuppkoppling och ingen router.

Det kan ju vara så att om du bor i lägenhet kan ju husägaren ha ett nätverk i huset, med router/switch och sedan därifrån ut på internet. Är det så får du knappast göra något i den routern. Eller har du ett "vanligt" abb?

Windows defender och windows brandvägg brukar lägga sig i lite för mycket. Har du stängt av defender och brandvägg och testat?

Din internetleverantör kan ha spärrat standardportarna som DC använder, har du testat andra? Se bara till att öppna i brandväggen om den är igång osv.

Link to comment
Share on other sites

Ursäkta inbrytningen...

Hur är det med Säkerhetscenter ? Nog borde du fått en varning om att du saknar antivirusskydd !?

Att köra DC++ utan skydd är som att älska utan... :P Lägg åtminstånde in AVG gratisprogrammet.

Instämmer!... Att överhuvudtaget koppla i nätkabeln utan fungerande antivirus och brandvägg, är i dag inte att tänka på.

Jag har haft ADSL i snart 11år, innan dess hade jag ISDN duo (dubbla linjer) och har aldrig haft en aktiv brandvägg. Har sedan vista kom in avaktiverat även defender. Kör AVG AV. Har 4 datorer i mitt nätverk och dessa går via en router ut på internet. En av datorerna är ansluten till internet 24/7 har aldrig haft något "skit" på datorn. Så brandväggar och liknande är överskattat för hemmaanvändare så länge man har en liten aning om vad man håller på med.

Folk må kalla mig idiot eller liknande, men varför ha något som krånglar till saker, samt belastar datorn när det inte behövs?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...