Går inte att strömma video via router


Recommended Posts

Hej!

Jag har en D-Link Dir-635 router hemma som jag kör trådlöst till min bärbara Vista-dator och med kabel till min stationära XP-dator.  Det har fungerat bra förutom när jag försöker att titta på t.ex. nyhetssändningarna på SVT:s hemsida. Då börjar det buffra med jämna mellanrum så att man får långa avbrott i klippen. Det blir samma sak på både den trådlösa och trådbundna förbindelsen. När jag testar bredbandshastigheten med www.bredbandskollen.se så får jag ca 9 Mbit/s i båda riktningarna.

När jag stoppar in nätverkskabeln direkt i bredbandsuttaget så fungerar det klanderfritt!

Vad kan detta bero på?? Varför blir det täta avbrott trots att bredbandskollen visar bra hastighet? Måste några speciella portar forwarderas för att strömmande video ska gå snabbare? Någon annan inställning som bör göras i routern?

Känner mig tyvärr rätt så handfallen inför detta problem så är tacksam för alla tips.

Link to comment
Share on other sites

Sidan 34 i manualen... QoS Engine... bocka i alla 3 under Streamengine Setup.

Sidan 44 i manualen... Advanced Network Settings... bocka i Enable Multicast Streams.

Allt detta var som det skulle. Jag hade faktiskt varit in och kollat på dessa inställningar tidigare utan att ha läst så noga i manualen.. :)

Några fler idéer? Kan routern behöva resettas?

Link to comment
Share on other sites

Sidan 34 i manualen... QoS Engine... bocka i alla 3 under Streamengine Setup.

Sidan 44 i manualen... Advanced Network Settings... bocka i Enable Multicast Streams.

Allt detta var som det skulle. Jag hade faktiskt varit in och kollat på dessa inställningar tidigare utan att ha läst så noga i manualen.. :)

Några fler idéer? Kan routern behöva resettas?

Njaee.... reset återställer ju bara fabriksinställningarna! En omstart kan däremot vara nyttig ibland, om något krånglar!

Link to comment
Share on other sites

Sidan 34 i manualen... QoS Engine... bocka i alla 3 under Streamengine Setup.

Sidan 44 i manualen... Advanced Network Settings... bocka i Enable Multicast Streams.

Allt detta var som det skulle. Jag hade faktiskt varit in och kollat på dessa inställningar tidigare utan att ha läst så noga i manualen.. :)

Några fler idéer? Kan routern behöva resettas?

Njaee.... reset återställer ju bara fabriksinställningarna! En omstart kan däremot vara nyttig ibland, om något krånglar!

Omstart har jag gjort flera gånger.

Link to comment
Share on other sites

Jag har även kollat upp detta och det är senaste firmware i routern.

Återstår då bara att reklamera routern?? Eller är den helt enkelt inte tillräckligt bra för att klara vissa videoklipp.

Kör själv med den trådade varianten av samma router, och har aldrig haft några sådana problem, Eftersom du säger att det är samma sak även när du kör med kabel, så börjar det väl luta åt något fel som är trasigt ja!  :-

Link to comment
Share on other sites

  • 3 months later...

Jag har nu tagit tag i detta igen och äntligen fått det att fungera klockrent. Jag kontaktade D-Links support och fick rådet att avbocka RTSP i routern. Det hittar man under Advanced/Firewall Settings under rubriken Application Level Gateway Configuration.

ALG (dvs. Application Gateway Configuration) förklaras på följande sätt:

Here you can enable or disable ALGs. Some protocols and applications require special handling of the IP payload to make them work with network address translation (NAT). Each ALG provides special handling for a specific protocol or application. A number of ALGs for common applications are enabled by default.

Och just för RTSP står det:

Allows applications that use Real Time Streaming Protocol to receive streaming media from the internet. QuickTime and Real Player are some of the common applications using this protocol.

Men uppenbarligen ställer detta till det när man använder Windows Media Player (har inte testat med Real Player) på t.ex. SVT.

Är det någon som kan förklara lite mer ingående vad min ändring innebär rent tekniskt och varför det hackade när jag hade rutan för RTPS ibockad? Tycker att det är konstigt att den är ibockad default om det inte behövs.

Men även fast jag inte förstår exakt varför det fungerar nu så är det ju skönt att det fungerar! :)

Link to comment
Share on other sites

Jag har nu tagit tag i detta igen och äntligen fått det att fungera klockrent. Jag kontaktade D-Links support och fick rådet att avbocka RTSP i routern. Det hittar man under Advanced/Firewall Settings under rubriken Application Level Gateway Configuration.

ALG (dvs. Application Gateway Configuration) förklaras på följande sätt:

Och just för RTSP står det:

Men uppenbarligen ställer detta till det när man använder Windows Media Player (har inte testat med Real Player) på t.ex. SVT.

Är det någon som kan förklara lite mer ingående vad min ändring innebär rent tekniskt och varför det hackade när jag hade rutan för RTPS ibockad? Tycker att det är konstigt att den är ibockad default om det inte behövs.

Men även fast jag inte förstår exakt varför det fungerar nu så är det ju skönt att det fungerar! :)

D-Links accesspunkter är inte direkt lämpliga att använda för strömmande media speciellt inte om det förekommer störningar från intilliggande nät i närheten. Ruckus Wireless klarar detta mycket bättre. Titta här: http://www.nowire.se/produkter/ruckus-mediaflex.htm

Link to comment
Share on other sites

D-Links accesspunkter är inte direkt lämpliga att använda för strömmande media speciellt inte om det förekommer störningar från intilliggande nät i närheten. Ruckus Wireless klarar detta mycket bättre.

Har du sett detta i några tester eller är det egna erfarenheter? Varför är det just för strömmande media som D-Link skulle fungera dåligt?

För mig fungerar det i alla fall bra nu efter att jag ändrade den där inställningen för RTSP.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share