Jump to content

Problem med trådlös anslutning äldre dator


Mikael63

Recommended Posts

Problemet gäller en gammal dator som jag skrivit om i annan tråd och i ett av inläggen där beskriver jag problem nätverksanslutningen.

Dessa problem har fortsatt. Det kan vara omväxlande "ansluten men inget internet" och "kunde inte ansluta till nätverket".

Någon gång har "felsökaren" åtgärdat problemet och så har det fungerat ett tag. Nu idag när jag startade upp var det omöjligt att kunna ansluta till nätverket.

Har testat med datorleverantörens (Fujitsu) driver (för Windows 7) men jag får info att Microsofts driver är bättre. Så hittade jag hos Dell en drivrutin med exakt samma namn men den är inte heller för Win10-64 och då fungerade det direkt att ansluta. Det höll i sig i säkert hela 13 minuter. Nu går det ansluta men inget internet.

I Linux kan man vid liknande problem starta om själva nätverkshanteraren vilket brukar medföra att det lirar igen. Finns kommando för det även i Windowsmiljö?

Att slå av/på nätverkskortet med fysisk knapp, som finns på den datorn, påverkar inget.

Är ju inte jätteviktigt, jag har W10 på den datorn bara för att jag testade att installera och kan testa diverse program utan att söla ner jobbardatorn.

Intel Wireless WiFi Link 4965AGN
EnhetsId 8086/4229
Fujitsu Lifebook E series E8410

Link to comment
Share on other sites

Du kan pröva med det här:

Citat

You can also use the Command Prompt to restart any connected network adapter. Here is how:

  1. Run the Command Prompt with administrative privileges.

  2. List all the network adapter details with this command:

    netsh interface show interface
  3. Note down the name of the network adapter that you want to restart/disable.

  4. Now use this command while entering your adapter’s name in place of [NetworkAdapterName] to disable it:

    netsh interface set interface “[NetworkAdapterName]” disable
  5. To re-enable the adapter, use this command:

    netsh interface set interface “[NetworkAdapterName]” enable

https://www.itechtics.com/disable-enable-restart-network-adapter/

Där finns tips på andra sätt att göra samma sak också.

  • Thanks 1
Link to comment
Share on other sites

21 timmar sedan, Cecilia sade:

use the Command Prompt

Ja det hade ju varit smidigt med en .bat för att hantera detta.

Dock så hänger sig kommandot på "disable" och enda vägen att få tillbaks kortet är en omstart.

  • Sad 1
Link to comment
Share on other sites

  • 3 weeks later...

Fick påminnelse - "vilket svar var mest hjälpsamt" - för några dagar sedan. Tänkte då svara att det verkade som att det behövdes få in alla Windowsuppdateringar, vilket tar tid när uppkoppling saknas titt som tätt. Startade upp den aktuella datorn men då var det stopp igen.

Avinstallerade kortet via Enhetshanteraren och valde att även ta bort drivrutiner.

On 2024-04-28 at 22:58, X-Men sade:

ett PM

Installerade då Intels nyaste mjukvara, alltså inte enbart en driver, från paketet ovan. Funkade direkt. Fick en annan sådan påminnelse (annan tråd) och tänkte att jag skulle meddela det jag skrivit ovan men startar upp på nytt och då är det åter stopp. Denna gång testade jag att avaktivera nätverkskortet och aktiverade det igen. Då hoppar allt igång. Något lurt är det...

I Linuxmiljö inga problem med nätverket, kanske ska ses som "ett tecken"?

  • Thanks 1
Link to comment
Share on other sites

Jag hade en gång en Fujitsu PA3553, bärbar dator med Windows Vista från början (bytte till Windows 7 när den versionen kom) som aldrig startade WLAN när datorn startades. Varje gång datorn startades krävdes det att jag aktiverade nätverkskortet för det trådlösa.

Jag skapade en .vbs-fil som jag lade in i Start/Program/Startup som gjorde att skriptet startades med datorn och därmed aktiverade nätverkskortet. Kanske kan detta vara en vägledning för dig om du funderar på att skapa ett skript som gör samma sak med din dator. Kanske fungerar skriptet redan från början med din dator eftersom du har en Fujitsudator.

 

Set WshShell = WScript.CreateObject("WScript.Shell")
Set oExec = WshShell.Exec("C:\Program Files\Launch Manager\WisWBSet.exe")
do while WshShell.AppActivate("Wireless Status Option")=False
WScript.Sleep 100
loop
WScript.Sleep 100
WshShell.sendkeys("{TAB}{TAB}{LEFT}~")

 

Använd Anteckningar när du kopierar in skriptet. Spara sedan som .vbs, t.ex. wlan.vbs.

  • Haha 1
Link to comment
Share on other sites

Det programmet/sökvägen fanns inte. Hämtade hem det, eller ett till "någon dator", från Fujitsu. Det har ett GUI som man kan köra (det som skriptet kör i bakgrunden) men alternativen är alla utgråade. Avinstallerade programmet.

Link to comment
Share on other sites

On 2024-04-28 at 17:40, Cecilia sade:

Där finns tips på andra sätt att göra samma sak också.

 

On 2024-04-29 at 15:27, Mikael63 sade:

Ja det hade ju varit smidigt med en .bat för att hantera detta.

Dock så hänger sig kommandot på "disable" och enda vägen att få tillbaks kortet är en omstart.

Jag antog, felaktigt tydligen, att "snuffarna" skulle vara kvar..

image.png.53ce159e6d47536226d698030457d4d2.png

 

..så att det i mitt fall då skulle bli..

netsh interface set interface “Wi-Fi” disable

..men det ska inte vara några snuffar!

netsh interface set interface Wi-Fi disable

 

  • Like 2
Link to comment
Share on other sites

Nätverkskortet är en gammal modell och lanserades kort innan N-standarden beslutades. Har du testat att ändra inställningarna för nätverkskortet till att enbart köra i b/g-läget och inaktivera n-stödet?

Förvisso kan du inte använda WPA-kryptering när du kör med b/g-läget enbart men du får en möjlighet att testa om kortet håller kvar uppkopplingen när n-läget inaktiverat. Om nätverkskortet håller uppkopplingen med enbart b/g-läget kan du utgå från att stödet för n-nätverk inte fullt ut fungerar med Windows 10.

Link to comment
Share on other sites

Det är uppenbart att det inbyggda nätverkskortet inte fungerar särskilt bra i Windows 10.

 

https://www.amazon.se/TP-Link-TL-WN823N-USB-WiFi-adapter-Svart/dp/B0088TKTY2/

Billig lösning! 96 kronor 

 

https://www.amazon.se/TP-LINK-MU-MIMO-Wireless-Supports-T3U/dp/B07M69276N/

Inte så dyr lösning och modern. 209 kronor.

Det finns alternativ som kostar mindre men är av okänt fabrikat. 

Link to comment
Share on other sites

Krypteringen är WPA2-Personal.

Idag räckte det med att välja Anslut kryssrutan med anslut automatiskt var/är i-bockad.

Öppet nätverk skulle innebära meck med routern och det är inte ett alternativ.

Link to comment
Share on other sites

Mest egen minnesanteckning.

Började om. Avinstallerade det som fanns. Installerade drivers hämtade från Fujitsu. Denna gång den exe som fanns i paketet. Förra gången troligen enbart drivern (Uppdatera, välj plats osv..) Startat om några gånger. Tycks fungera så som man trott tidigare. Skulle skriva detta här men i samband med en varningsruta om att brandväggen inte var aktiverad kopplades nätverket bort och Windows hängde sig med "DPC WATCHDOG VIOLATION".

Startade om och inväntade den varningen angående brandväggen men denna gång lirar det...

Packar undan den datorn nu..

Link to comment
Share on other sites

Om det faktiska problemet, att nätverket kopplas ifrån/ej ansluts, vet jag inte om är löst. Det skulle behövas fler starter för det.

Däremot upplever jag inget problem iom att datorn inte används 😃

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...