[LÖST] Windows Installer-problem, det verkar inte fungera


L-L

Recommended Posts

Hej, sitter här med mina föräldrars dator - Windows XP SP2. Har upptäckt ett allvarligt bekymmer - Windows Installer tycks inte fungera. Detta leder till att t.ex. MS Office inte startar, och installationsprogrammet vill inte heller starta. Jag kan alltså inte ens ominstallera Office.

Följande meddelande kommer vid försök till avinstallation av Office:

"Det gick inte att komma åt tjänsten Windows Installer. Detta kan hända om du kör Windows i felsäkert läge eller om Windows Installer inte är korrekt installerat. Kontakta företagets supportavdelning för ytterligare hjälp."

Med denna ledtråd kollade jag upp tjänsten i fråga. Den står på manuell, och är inte startad. När jag försöker starta tjänsten kommer följande meddelande:

"Tjänsten Windows Installer på Lokal dator startade och stoppade igen. Vissa tjänster stoppar automatiskt om de inte behövs. Ett exempel på detta är tjänsten Performande Logs and Alerts."

Vad kan man göra nu? Om inte denna tjänst fungerar så går det ju varken att uppdatera program, eller just nu ännu värre, ens att starta MS Office.

Tacksam för hjälp.

LA

Länk till inlägg
Dela på andra webbplatser

Bara några teorier.... ;)

har du kollat    update.microsoft.com

Då får man med även Servicepacket för Office...  SP3

Dito varför OSet är på Sp2 ?

Windows Installern har hursomehlst en ny version just nu.

(är för lat och kolla hos MS vilken version som nu gäller)

Länk till inlägg
Dela på andra webbplatser

Ett tips på nätet var att se till att man verkligen var Administratör...

ett annat var att rensa upp i katalogen "c:windowsinstaller"

Tjänsten ska stoppas efter att eventuellt uppdrag är klart eller har misslyckats..

Jag startade tjänsten och den håller igång......

Kolla att tjänsten "Remote Procedure Call (RPC)" snurrar eftersom Win Inst. är beroende av den.

Kolla även:  http://support.microsoft.com/kb/555175

Run CMD.exe

>  msiexec /unreg

>  msiexec /regserver

Länk till inlägg
Dela på andra webbplatser
ett annat var att rensa upp i katalogen "c:windowsinstaller"

Hur gör man det på ett säkert sätt? Jag rensade en gång med Windows Installer Clean Up, och det ledde till att jag fick ominstallera en del program.

Länk till inlägg
Dela på andra webbplatser

ett annat var att rensa upp i katalogen "c:windowsinstaller"

Hur gör man det på ett säkert sätt? Jag rensade en gång med Windows Installer Clean Up, och det ledde till att jag fick ominstallera en del program.

Jo jag föredrar MS clean up metod

http://support.microsoft.com/kb/290301

Men... i det här fallet är det ju oklart vart uppdateringarna är mer än att det är SP2 på XP

och det borde går bra.

Vart office är någonstans är oklart.... kör man senaste uppdateringarna får man ta till clean up toolen

om det inte går att fixa.  Office 2007 är ett krux om man läser MS skrivning.

Länk till inlägg
Dela på andra webbplatser
Hur gör man det på ett säkert sätt? Jag rensade en gång med Windows Installer Clean Up, och det ledde till att jag fick ominstallera en del program.

Detta var bara ett förslag som hjälpte en annan med XP. Du kan ju testa de andra förslagen först så.

I min testmiljö gjorde detta ingen skada... Du skulle kunna flytta undan dem istället för att se om det hjälper.

Länk till inlägg
Dela på andra webbplatser

Tack för alla svar! :)

Kan börja med att förtydliga; jag var inloggad på ett konto med adminbehörighet. Samma problem uppstod dock även på gästkontot.

Bara några teorier.... ;)

har du kollat    update.microsoft.com

Då får man med även Servicepacket för Office...  SP3

Dito varför OSet är på Sp2 ?

Windows Installern har hursomehlst en ny version just nu.

(är för lat och kolla hos MS vilken version som nu gäller)

Du kan ju prova att slänga in SP3 annars..... får du igång den, så löser det förmodligen problemet! ;)

http://www.microsoft.com/downloads/details...08-1e1555d4f3d4

Ett tips på nätet var att se till att man verkligen var Administratör...

ett annat var att rensa upp i katalogen "c:windowsinstaller"

Tjänsten ska stoppas efter att eventuellt uppdrag är klart eller har misslyckats..

Jag startade tjänsten och den håller igång......

Kolla att tjänsten "Remote Procedure Call (RPC)" snurrar eftersom Win Inst. är beroende av den.

Kolla även:  http://support.microsoft.com/kb/555175

Run CMD.exe

>  msiexec /unreg

>  msiexec /regserver

Det är SP2 då jag inte ansvarar för datorn och mina föräldrar inte har så bra koll. ;) Kanske skulle SP3 och/eller ny version av Windows Installer hjälpa, men jag undrar om det ens skulle gå att starta en installation av SP3 då tjänsten Windows Installer inte tycks fungera. Det blir ju moment 22. :-

Att rensa upp i WindowsInstaller borde väl bara leda till att installations-funktionen för div. program inte längre fungerar? Filerna i den mappen ligger ju inte där utan anledning.

RPC bör vara igång, jag har aldrig rört tjänsterna på denna dator, till skillnad från min egen dator med 8 tjänster. ;D

Sitter inte vid datorn nu, och kommer inte att göra det förrän tidigast om en vecka, så jag får återkomma då! En näst sista utväg jag ser är att reparera Windows med en installations-CD (vilket mina föräldrar inte har då de bara har recovery-skivor, men i386-mappen finns som en räddare i nöden). Och den sista utvägen blir väl att installera om alltihop, vilket det ändå kan vara läge att göra snart.

Tack igen,

LA

Länk till inlägg
Dela på andra webbplatser

Endast en ominstallation av Windows verkade kunna lösa problemet. Jag testade allt ni skrev, utan framgång. Det gick dock att starta installationen av SP3, men den stötte på error under resans gång och rullade tillbaka allt.

Så efter en natt av väntan har jag lagt in Windows XP (helt utan SP) från recovery-skivor, varefter jag försökte köra SP3 men den krävde att jag hade minst SP1 i grunden - vilket jag inte lyckade hitta på M$ hemsida (den skickade mig till SP3 i stället >:() - varpå jag lade in SP2 och sedan SP3... vilken röra, men nu äntligen är allt uppe och i ordning. Bortsett från gästkontot som hade problem. Fick ta bort det och ersätta med ett vanligt konto (med begränsade rättigheter).

Trots alla mina ansträngningar att göra systemet snyggt (även om jag har varit försiktig i rensningen och dessutom inte rört tjänsterna, bara autostart) och lägga in de bästa programmen så känns datorn ganska slö. Men så är den ju från 2002 också och den var ingen värsting då.

Problemet löst.

LA

Länk till inlägg
Dela på andra webbplatser

Arkiverat

Detta ämne är nu arkiverat och det går inte längre svara i det.