Jump to content

Kan ej använda integrerad grafik


Up2

Recommended Posts

Jag plockade precis ihop en dator som är tänkt att användas för att surfa med. Den innehåller ganska enkla delar:

400 Watts nätaggregat

1 st chassifläkt

MSI G31TM-P35 moderkort

2.5 GHz Dual Core-processor

160GB SATA 2-hårddisk

SATA DVD-läsare/brännare

Identiska 2 GB DDR2 PC2 6400-minnen

SoundBlaster Audiogy 2 ZS-ljudkort (måste användas på grund av att chassit som egentligen är ett gammalt HP-chassi har hörlurs- och mikrofonuttag på framsidan med en speciell, bred men inte stor, vad jag tror är strömkontakt förutom den där CDINPUT-kontakten som många moderkort brukar ha. Liknar den som äldre CD-läsare har.)

Problemet är är att jag inte kan använda den integrerade grafiken ordentligt. Alla delarna fungerar för att de är tysta, testade i en annan dator och knappt använda. BIOS hittar allt, etc.

Win 7-installationen går igenom utan problem, men mitt under de allra första uppdateringarna man får när man kommer in i Windows, så startar den plötsligt om och frågar om jag vill boota in i Felsäkert läge, etc. XP-installationen däremot startas atuomatiskt om när den installerar enheter, runt 30 minuter kvar av installationen. Sen vill den börja om installationen.

Jag testade att stoppa i ett PCI-E-kort och då gick installationen igenom, men i Windows kan jag hämta och installera drivrutinerna för allt utom den integrerade grafiken (både från MSI och Intels hemsida) för att den av någon anledning inte stöds ("Datorn uppfyller inte minimikraven för att installera programvaran. Installationen avslutas"). Försöker jag ta ut grafikkortet och starta XP, så startar den om efter precis innan inloggningsskärmen.

Win 7 hittar det integrerade grafikkortet och installerar till och med en nyare version helt automatiskt, men startar som sagt om sig efter ett tag. Jag har testat att ladda hem samma drivrutin från MSI.

BIOS verkar inte klaga på värmen. Chassit är dessutom säkert tre gånger större än moderkortet och alla sladdarna är utbytta.

Jag vill trots allt att det ska vara en tyst dator utan en massa extra kort och delar.

Tack på förhand och god fortsättning!

EDIT: Kan en BIOS-uppdatering hjälpa?

Edited by Up2
Link to comment
Share on other sites

Normalt brukar den integrerade grafiken och ev ljud att installeras från moderkortets tillverkare.

Börja med chipset drivrutiner sedan grafik för ditt chip och sedan ljud om det behövs.

Vilket moderkort är det frågan om?

Link to comment
Share on other sites

Normalt brukar den integrerade grafiken och ev ljud att installeras från moderkortets tillverkare.

Börja med chipset drivrutiner sedan grafik för ditt chip och sedan ljud om det behövs.

Vilket moderkort är det frågan om?

Ett MSI G31TM-P35 och som jag skrev så kan jag installera alla drivrutiner förutom det till den integrerade grafiken under XP. Windows 7 hittar allt automatiskt, och det går att installera uppdaterade drivrutiner till chipset och resten om jag så vill.

Link to comment
Share on other sites

Men jag behöver ju ett grafikkort i datorn under XP-installationen, annars startar den om när det står Enheter installeras eller något liknande. Det har jag i och för sig, men ska jag låta det sitta i tills efter att jag har installerat grafikdrivrutinen i felsäkert läge och sedan starta om datorn i vanligt läge utan PCI-E kortet?

Link to comment
Share on other sites

Det gick inte. Jag började med drivrutinerna för chipset, sedan nätverkskortet, ljudkortet och sist grafikkortet. Men jag fick ändå samma felmeddelande. Bör jag lägga ner och skaffa ett annat moderkort?

Link to comment
Share on other sites

Yep, det är oftast ett "MÅSTE"....

http://msi.com/produ...html#/?div=BIOS

Sen har du även drivarna hos MSI.....

Jag installerade något Live Update 5-program från MSI och den laddade ner och installerade en BIOS-uppdatering. Allt verkade okej och datorn startade om. Men nu kommer det roliga: skärmen får ingen signal med PCI-E-kortet inkopplat trots att det i BIOS står inställt som Primary Graphics Adapter. Däremot fungerar det integrerade men datorn startar ändå om efter någon minut då man kommit in i Windows.

Frågan är om moderkortet stör sig på Windows, och varför?

Edited by Up2
Link to comment
Share on other sites

Ett Nvidia Geforce 9300 GT. Helt fungerande från en annan dator. Jag skrev precis att när jag kopplar ur kortet ur datorn och stoppar skärmkabeln i moderkortets integrerade grafikkontakt så får jag bild på skärmen. Men sen startar datorn om sig bara någon minut efter att man har kommit in i Windows. Vid sista försöket startade den om sig vid XPs laddningsskärm (svart bakgrund med loggan och laddningsgrejen).

Link to comment
Share on other sites

Ett Nvidia Geforce 9300 GT. Helt fungerande från en annan dator. Jag skrev precis att när jag kopplar ur kortet ur datorn och stoppar skärmkabeln i moderkortets integrerade grafikkontakt så får jag bild på skärmen. Men sen startar datorn om sig bara någon minut efter att man har kommit in i Windows. Vid sista försöket startade den om sig vid XPs laddningsskärm (svart bakgrund med loggan och laddningsgrejen).

Ok....Jo är det ett nVidiakort dessutom ett som inte är något högpresterande dvs under X500 så måste du nog ladda ner drivarna från nVidia.

http://www.nvidia.co...aspx?lang=en-us

--

Edited by plun
Link to comment
Share on other sites

En BIOS-version verkar enligt MSI inte hjälp ditt specifika problem. I windows 7 låter det som att den försöker ta hem en kritiskt uppdating för grafikkortet, men inte lyckas. Om du gör uppdateringen manuellt och ser till att välja att inte installera drivrutinen för grafikkortet, fungerar det då? Problemet kan vara att ibland släpps det kritiska drivrutinsuppdateringar som installeras automatiskt. Syftet är naturligtvis att det ska förbättra snarare än försämra läget men i detta fall verkar det vara tvärtom.

Link to comment
Share on other sites

En BIOS-version verkar enligt MSI inte hjälp ditt specifika problem. I windows 7 låter det som att den försöker ta hem en kritiskt uppdating för grafikkortet, men inte lyckas. Om du gör uppdateringen manuellt och ser till att välja att inte installera drivrutinen för grafikkortet, fungerar det då? Problemet kan vara att ibland släpps det kritiska drivrutinsuppdateringar som installeras automatiskt. Syftet är naturligtvis att det ska förbättra snarare än försämra läget men i detta fall verkar det vara tvärtom.

Grejen är att Win 7 redan har en drivrutin installerad så Aero och alla andra effekter flyter på när jag kommer till skrivbordet för första gången efter Windows-installationen, och den försöker inte hämta någon annan drivrutin automatiskt eftersom den finns bland Valfria uppdateringar i Windows Update (den enda gången jag lyckades komma så långt inom 1-2 minuter). Skillnaden mellan de två är versionsnummer t.ex 10.5.13 -> 10.5.14. Dessutom händer ju exakt samma sak i XP, fast då måste jag installera drivrutiner för alla komponenter i datorn, vilket gör att XP omöjligt kan hämta en annan version av standarddrivrutinen, som i XP ger mig 800x600 i upplösning. 7an visar rätt upplösning från början som ska vara 1440x900.

Edited by Up2
Link to comment
Share on other sites

Jo men hade du nVidia-kortet i så måste drivarna blivit installerade dvs MS versionen.

Har du kollat Enhetshanteraren ?

När jag väl lyckas komma in i Enhetshanteraren i Felsäkert läge så står den högst upp i listan tillsammans med det integrerade grafikkortet och en liten varningssymbol. Den här gången i XP.

Edited by Up2
Link to comment
Share on other sites

Har du provat med att "slip streama" en installations skiva för Xp eller W7 ?

Lägg in det som "behövs"..

http://www.nliteos.com/nlite.html

http://www.intowindo...-for-windows-7/

http://www.vlite.net/about.html

Känner till metoden, men har aldrig provat att göra det. Jag menar, så långt ska man väl inte behöva gå. Linux är inget alternativ då den personen som ska få datorn inte kan mer än att öppna en webbläsare, läsa Aftonbladet ett par minuter, kolla e-posten och sedan gå därifrån.

Edited by Up2
Link to comment
Share on other sites

Misstänker att SATA-drivrutinerna inte fungerar som det skall. Visserligen "brukar" man inte komma så långt med

installationen som du har lyckats med,, det brukar bli en blå skärm tidigare om det inte fungerar.

Vet ej hur det är med Windows 7, men den ska nog normalt sett kunna hitta rätt SATA-drivrutin.

Infoga bara .INF drivrutinen ifån MSI till nlite eller vlite, och att du har tillgång till Xp- och W7 skiva/dator.

http://msi.com/product/mb/G31TM-P35.html#/?div=Driver&os=All

http://www.wikihow.com/Slipstream-Your-SATA-Drivers-Into-a-Windows-XP-Installation-CD-Using-nLite

http://www.sevenforums.com/tutorials/72185-sata-drivers-slipstream-into-windows-xp-cd.html

Link to comment
Share on other sites

När jag väl lyckas komma in i Enhetshanteraren i Felsäkert läge så står den högst upp i listan tillsammans med det integrerade grafikkortet och en liten varningssymbol. Den här gången i XP.

Knepigt... jag fattar inte heller vad som bootar om burken.

I många BIOS kan man sedan styra om det integrerade eller externa grafikkortet ska användas. (kanske blitt nåt knas där ?) annars så brukar det hjälpa att ladda om BIOS med "default" värden.

Slutligen kan det vara så surt att du bör göra en ny ren installation.

Link to comment
Share on other sites

Skulle nog vilja säga två saker, när du monterade moderkoret kollade du så att det inte finns några metalliska delar som kan få kontakt med moderkortet, då det är ett s.k OEM chassi så kan det ha avvikande platser för skruvhål eller liknande..

Provat att köra det utan ditt soundblasterkort, om allt annat är nytt utom detta?

Vad står det i Windows 7 Loggboken (kontrollpanelen -> administrationsverktyg -> datorhantering)

står det något där vad dessa omstarter beror på?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...